<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<title>Dagger Movie Night: &#8220;Beauty and the Beast&#8221; &#8211; Stale and Old as Time</title><meta name="robots" content="noodp,noydir" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Dagger Movie Night: &#8220;Beauty and the Beast&#8221; &#8211; Stale and Old as Time Comments Feed" href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.8"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=4.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=1.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.5.4' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ulike_obj = {"ajaxurl":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","button_text_u":"Unlike","button_text":"Like","button_type":"image"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-scripts.min.js?ver=1.2.2'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F03%2F16%2Fdagger-movie-night-beauty-and-the-beast-stale-and-old-as-time%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F03%2F16%2Fdagger-movie-night-beauty-and-the-beast-stale-and-old-as-time%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="Shortcut Icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" type="image/x-icon" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover { background-color: #999999 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 19px; padding: 10px; }  .simple-social-icons ul li a:hover { background-color: #666666 !important; border-color: #ffffff !important; color: #ffffff !important; }</style><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Dagger Movie Night: &quot;Beauty and the Beast&quot; - Stale and Old as Time" />
<meta property="og:url" content="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/" />
<meta property="og:description" content="Somewhere in a parallel universe, Disney produced a live-action “Beauty and the Beast” directed by Guillermo del Toro. No singing; just dark beauty, true to the source. Somewhere in time and space,..." />
<meta property="article:published_time" content="2017-03-17T01:47:23+00:00" />
<meta property="article:modified_time" content="2017-03-17T01:50:35+00:00" />
<meta property="article:author" content="http://www.daggerpress.com/author/erik-kristopher-myers/" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-01-1.jpg" />
<meta property="og:image" content="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-poster.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-poster.jpg?w=240" />
<meta name="twitter:card" content="summary" />

<!-- BEGIN GADWP v4.9.2 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->


<style id="custom-css-css">@import "http://fonts.googleapis.com/css?family=Droid+Sans";.entry-title{font-size:3.2rem;font-weight:800}.after-entry .widget-title,.archive-title,.comments-title,.widget .entry-title{font-size:1.5rem}.title-area{float:left;padding:0;width:302px}.header-image .site-title a{background-color:none;max-width:302px;min-height:80px;padding:0}.site-header .widget-area{float:right;width:728px}.breadcrumb{font-size:1.2rem}@media only screen and (max-width: 728px){.title-area{width:100%}.site-header .widget-area{width:100%}}body{font-family:'Droid Sans', sans-serif}blockquote,blockquote::before{color:#555}</style>
</head>
<body class="single single-post postid-108948 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope="itemscope" itemtype="http://schema.org/WebPage"><nav class="nav-secondary" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/">About The Dagger</a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/">Advertise</a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/">Contact Us</a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/">Terms of Service</a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div><header class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><aside class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section></aside></div></header><nav class="nav-primary" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/">Local</a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/">Politics</a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/">Schools</a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/">Sirens</a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/category/question-2/">Big Q</a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/">Health/Food</a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/">A&#038;E</a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/">Sports</a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar.shtml">Events</a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" role="main" itemprop="mainContentOfPage" itemscope="itemscope" itemtype="http://schema.org/Blog"><div class="breadcrumb">You are here: <a href="http://www.daggerpress.com/">Home</a> / <a href="http://www.daggerpress.com/category/pop-culture/">Arts</a> / Dagger Movie Night: &#8220;Beauty and the Beast&#8221; &#8211; Stale and Old as Time</div><article class="post-108948 post type-post status-publish format-standard category-pop-culture category-movies-pop-culture tag-beauty-and-the-beast tag-disney tag-emma-watson tag-josh-gad tag-live-action tag-luke-evans tag-movie tag-new tag-review tag-theaters entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Dagger Movie Night: &#8220;Beauty and the Beast&#8221; &#8211; Stale and Old as Time</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-03-16T21:47:23+00:00">March 16, 2017</time> By <span class="entry-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a href="http://www.daggerpress.com/author/erik-kristopher-myers/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Erik Kristopher Myers</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><a href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/s-beauty-and-the-beast-poster/" rel="attachment wp-att-108949"><img src="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-poster.jpg" alt="S beauty and the beast poster" width="203" height="300" class="alignleft size-full wp-image-108949" /></a></p>
<p>Somewhere in a parallel universe, Disney produced a live-action “Beauty and the Beast” directed by Guillermo del Toro. No singing; just dark beauty, true to the source. Somewhere in time and space, that film is unspooling in a theater even as I write this, and a new generation of children – girls and boys alike – are discovering this story for the first time. Meanwhile, their parents, raised on The House of Mouse, are marveling at the rewards found in risk and artistic expression.</p>
<p>We don’t live in that universe.  All we get is a remake of a cartoon that didn’t need remaking.</p>
<p>It becomes immediately apparent during the show-opening musical montage (“Belle”) that this live-action retelling of “Beauty and the Beast” is substantially less life-like than its animated predecessor. The musical montage that’s unwisely built around Emma Watson’s auto-tuned vocals looks like a car commercial: the same lighting, the same slick camera moves, but with actors who can’t muster the charm and dynamism of a Ford Focus. It’s like the world’s most expensive high school production, or a reenactment starring amusement park employees.</p>
<p><a href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/s-beauty-and-the-beast-01-2/" rel="attachment wp-att-108954"><img src="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-01-1.jpg" alt="S beauty and the beast 01" width="400" height="234" class="alignright size-full wp-image-108954" srcset="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-01-1-300x176.jpg 300w, http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-01-1.jpg 400w" sizes="(max-width: 400px) 100vw, 400px" /></a></p>
<p>While one can appreciate the urge to translate a beloved cartoon classic into live action, it’s one of those urges best resisted, like McDonalds, or cocaine. “Beauty and the Beast” commits the unforgivable sin of existing. It brings absolutely nothing new to the table save for a few new songs and a drippy subplot involving Belle (Watson) discovering the truth behind her mother’s death. Beyond that, it’s a remake so faithful that its fidelity renders it boring, and its failure to engage causes creepy subtext to rise to the surface.</p>
<p>After all, what is “Beauty and the Beast” if not a romantic take on Stockholm syndrome, anyway? The vicious (and unnamed) Beast (Dan Stevens) locks Belle away and, with the help of The Help (Ewan McGregor, Ian McKellen, and Emma Thompson), begins a courtship that involves keeping her prisoner while still doling out “favors” to appear benevolent. You want books? Here you go, little lady! Want to see your elderly father? Here’s a magic mirror! All this while throwing temper tantrums and stomping around the castle like a violent Teddy Ruxpin. Hobbled women are sighing and clutching their bosoms the world over.</p>
<p>While never the most politically correct love story ever told, “Beauty and the Beast” takes on a very uncomfortable quality in live action. We can sympathize with our heroine when she’s afraid of her jailer; we can understand when he pisses her off; but once she’s making Sex Eyes at a character who looks like the family dog, the whole thing starts feeling weird and gross. </p>
<p>The cast is fair but, like the production designers, they’re handcuffed to the 1991 film. Watson comes off like a resting-smirk-face teenager who time-travelled to that magical part of France where everyone speaks with British accents; she walks around like there’s a coat hanger in the back of her dress and puts on a fair show despite being the one non-vocalist onscreen. On the opposite end of the spectrum is Luke Evans, whose Gaston gives reason to reconsider an actor mostly pigeonholed to dour, mopey film roles. He’s charming, he’s likable, and when his pipes open, they roar.</p>
<p><a href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/s-beauty-and-the-beast-02-2/" rel="attachment wp-att-108955"><img src="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-02-1.jpg" alt="S beauty and the beast 02" width="400" height="186" class="alignleft size-full wp-image-108955" srcset="http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-02-1-300x140.jpg 300w, http://www.daggerpress.com/wp-content/uploads/S-beauty-and-the-beast-02-1.jpg 400w" sizes="(max-width: 400px) 100vw, 400px" /></a></p>
<p>Then of course there’s Josh Gad, around whom so much controversy has been spun. For all the outrage his homosexual take on LeFou is generating, his dinner theater schtick is the real offense; Josh Gad is as subtle as a kidney stone. And while the LOOK, HE’S GAY! moments are perhaps about ten too many, and seem to exist simply to draw attention to themselves rather than to say anything new or meaningful about the character, Gad commits to this reinterpretation; however, his inability to pick an accent and stay with it would suggest a tendency for LeFou to swing both ways.</p>
<p>Competent though they all might be, it’s baffling to think that no one considered Anna Kendrick, Dwayne Johnson, and Patton Oswalt in these roles, as each feels an obvious and far more appropriate alternative for a one-to-one remake of the animated film. Watson in particular is poorly suited for this sort of film, and seems destined for a Rupert Grint career rather than a Daniel Radcliffe-style reinvention.</p>
<p>No one can deny that “Beauty and the Beast” is an efficient and well-made film. Director Bill Condon vacillates between art (“Gods and Monsters,” “Dreamgirls”) and garbage (“The Twilight Saga”), but the quality of both his art and garbage always have a tendency to be high. The prevailing problem with “Beauty and the Beast” is how unnecessary it is, and how limiting to all participants both in front of and behind the camera. Rather than a new take on a tale that’s, yes, as old as time, Disney has simply pulled a reverse “Roger Rabbit” and dropped actors into the same fake environments, created this time with green screens and computers rather than drawn by hand. There’s no opportunity to explore or try anything new lest it raise the ire of devotees, as exemplified by the media furor over Josh Gad dropping a few winks and staring lustily at Gaston. </p>
<p>“Beauty and the Beast” is cinematic karaoke of the worst sort, and its inevitable success opens the door for the upcoming “Lion King” remake, as well as all the rest to follow. In many ways, it’s worse than simply copying an existing film – it’s in many ways closer to theft in its stunningly limited imagination.</p>
<p>Directed by Bill Condon<br />
Written by Evan Spiliotopoulos and Stephen Chbosky<br />
Rated PG for some action violence, peril and frightening images</p>
<p>Trailer</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/" data-layout="button_count"></div></li><li class="share-twitter"><div class="twitter_button"><iframe allowtransparency="true" frameborder="0" scrolling="no" src="http://platform.twitter.com/widgets/tweet_button.html?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F03%2F16%2Fdagger-movie-night-beauty-and-the-beast-stale-and-old-as-time%2F&#038;counturl=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F03%2F16%2Fdagger-movie-night-beauty-and-the-beast-stale-and-old-as-time%2F&#038;count=horizontal&#038;text=Dagger%20Movie%20Night%3A%20%22Beauty%20and%20the%20Beast%22%20-%20Stale%20and%20Old%20as%20Time%3A" style="width:101px; height:20px;"></iframe></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F03%2F16%2Fdagger-movie-night-beauty-and-the-beast-stale-and-old-as-time%2F&#038;description=Dagger%20Movie%20Night%3A%20%22Beauty%20and%20the%20Beast%22%20-%20Stale%20and%20Old%20as%20Time" data-pin-do="buttonBookmark" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-108948-58cf32df8f5ab' data-src='//widgets.wp.com/likes/#blog_id=2163858&amp;post_id=108948&amp;origin=www.daggerpress.com&amp;obj_id=2163858-108948-58cf32df8f5ab' data-name='like-post-frame-2163858-108948-58cf32df8f5ab'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height:55px'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"><p class="entry-meta"></p></footer></article>				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.daggerpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8"  aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" /></p>

<div class="captchaSizeDivLarge"><img id="si_image_com" class="si-captcha" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_form_id=com&amp;prefix=IqfmnDF3Ck88tm1X" width="175" height="60" alt="CAPTCHA Image" title="CAPTCHA Image" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="IqfmnDF3Ck88tm1X" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh Image" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_form_id=com&amp;prefix='); return false;">
      <img class="captchaImgRefresh" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh Image" onclick="this.blur();" /></a>
  </div>
  </div>
<br />
<p><label id="captcha_code_label" for="captcha_code" >CAPTCHA Code</label><span class="required">*</span>
<br /><input id="captcha_code" name="captcha_code" type="text" size="6"  />
</p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='108948' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1d66a0cbca" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="105"/></p>				</form>
					</div><!-- #respond -->
		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="search-form" action="http://www.daggerpress.com/" role="search"><input type="search" name="s" placeholder="Search this website&#x2026;" /><input type="submit" value="Search" /></form></div></section><section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;People should embrace who they are and be proud of their race and traditions. People should also be aware that&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386380" title="SoulCrusher | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>SoulCrusher</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Black lives matter can yammer on about killing whites, starting a race war and murdering police.  They get praise&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386376" title="I thought skinheads were bald | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>I thought skinheads were bald</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;yeah...except that it's not a failure.  Not even close.  Now Trumpcare...that would be a failure.  It woudl&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/#comment-386375" title="Disgusted | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;"><strong>Disgusted</strong> | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Why would the VFW rent to this group??&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386369" title="Iminbelair | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>Iminbelair</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Welcome to Trumpland!&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386367" title="Death of Democracy | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>Death of Democracy</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I wonder what would happen if killer clowns gathered here instead? WTF&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386366" title="WTF | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>WTF</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I wonder what would happen if the Black Panthers were gathering here instead.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/#comment-386365" title="Incredible | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa"><strong>Incredible</strong> | Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;News flash Billybob  Hillary lost.    Do yourself a favor and google up the veteran meeting you&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386363" title="Deer God | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Deer God</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You sound like you didn't get any education. Maybe you should have devoted more time to your education and less&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/comptroller-franchot-tours-havre-de-grace-middle-school-politicians-discuss-need-for-new-facility/#comment-386362" title="Just a guess | Comptroller Franchot Tours Havre de Grace Middle School; Politicians Discuss Need for New Facility"><strong>Just a guess</strong> | Comptroller Franchot Tours Havre de Grace Middle School; Politicians Discuss Need for New Facility</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Harford County doesn't need a new High School or Middle School.  The County Schools are no where near capacity.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/comptroller-franchot-tours-havre-de-grace-middle-school-politicians-discuss-need-for-new-facility/#comment-386361" title="We don't need no education | Comptroller Franchot Tours Havre de Grace Middle School; Politicians Discuss Need for New Facility"><strong>We don't need no education</strong> | Comptroller Franchot Tours Havre de Grace Middle School; Politicians Discuss Need for New Facility</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Billy Bob,    Are you a vet?  If so, do you receive care at a VA?&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386360" title="just a thought | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>just a thought</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;@Deer God    Correct, however he would have been had Hillary been elected.  Fortunately for America the&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386359" title="Billy Bob | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Billy Bob</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;News flash billybob this is gonna come as a shock to you but OBama isn't the President anymore.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386352" title="Deer God | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Deer God</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Deer God,    Au contraire.  The "Blueprint" is very specific about what Trump intends to do with&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386349" title="Ali Khat | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Ali Khat</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Happy Dan    Hear!!  Hear!!  American Vets deserve everything that was promised to them in addition&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386347" title="Ali Khat | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Ali Khat</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Why would anyone think that he speaks for you? It's her job to speak for all the people that she&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/#comment-386346" title="independent voter | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;"><strong>independent voter</strong> | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You don't speak for me. Repeal and replace Obamacare. In fact... let it implode, then replace it. Democrats need to&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/#comment-386345" title="MissingReagan | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;"><strong>MissingReagan</strong> | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Well, you should be livid that 600,000 were thrown into the street by Obama Care if the article you referred&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386344" title="Billy Bob | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Billy Bob</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The study you provided a link to is something that does nothing but “suggest”, “imply” and talk around what may&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386341" title="Deer God | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Deer God</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The study you provided a link to is something that does nothing but “suggest”, “imply” and talk around what may&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386340" title="Deer God | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Deer God</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I am not willing for ONE veteran who has sacrificed so much to lose healthcare because our so-called-president wants to&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386338" title="Happy Dan | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Happy Dan</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;@Happy Dan    I reviewed the article you provided a link for and extracted the following from that&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386335" title="Billy Bob | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Billy Bob</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Reminds me of the Lagmeister's meltdown back in the day.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/#comment-386334" title="Rockfish | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;"><strong>Rockfish</strong> | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Two quotes that bear repeating:            1)   "Let's&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/#comment-386331" title="Ms Steak | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;"><strong>Ms Steak</strong> | Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;600 thousand is the estimated number of vets, not including their spouses and children that are presently covered under OBamacare&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/#comment-386329" title="Duh | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake"><strong>Duh</strong> | Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section><section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
					<li>
				<a href="http://www.daggerpress.com/2017/03/19/effort-mobilizes-to-shut-down-purported-white-supremacist-event-in-joppa/">Effort Mobilizes to Shut Down Purported White Supremacist Event in Joppa</a>
							<span class="post-date">March 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/19/pair-of-pets-perish-in-fire-that-originated-in-laundry-room-of-joppa-home/">Pair of Pets Perish in Fire Originating in Laundry Room of Joppa Home</a>
							<span class="post-date">March 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/19/harford-community-college-president-meets-with-aberdeen-proving-ground-leadership/">Harford Community College President Meets With Aberdeen Proving Ground Leadership</a>
							<span class="post-date">March 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/19/fallston-group-director-of-marketing-kathy-walsh-named-2017-athena-award-winner/">Fallston Group Director of Marketing Kathy Walsh Named 2017 ATHENA Award Winner</a>
							<span class="post-date">March 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/17/discarded-smoking-materials-damage-joppa-home-arson-of-aberdeen-plumbing-truck-investigated/">Discarded Smoking Materials Damage Joppa Home; Arson of Aberdeen Plumbing Truck Investigated</a>
							<span class="post-date">March 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/17/del-szeliga-fighting-to-protect-and-preserve-obamacare-is-not-in-the-best-interest-of-the-citizens-of-maryland/">Del. Szeliga: &#8220;Fighting to Protect and Preserve Obamacare is Not in the Best Interest of the Citizens of Maryland&#8221;</a>
							<span class="post-date">March 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/17/comptroller-franchot-tours-havre-de-grace-middle-school-politicians-discuss-need-for-new-facility/">Comptroller Franchot Tours Havre de Grace Middle School; Politicians Discuss Need for New Facility</a>
							<span class="post-date">March 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/">Dagger Movie Night: &#8220;Beauty and the Beast&#8221; &#8211; Stale and Old as Time</a>
							<span class="post-date">March 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/16/del-glass-smart-meters-put-customers-at-risk-of-fire-illness-hacking-for-benefit-of-utility-companies/">Del. Glass: Smart Meters Put Customers at Risk of Fire, Illness, Hacking for Benefit of Utility Companies</a>
							<span class="post-date">March 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/16/trump-budget-shuts-down-chesapeake-bay-clean-up-proposed-budget-puts-drinking-water-sources-at-risk-for-13-million-bay-residents/">Trump Budget Shuts Down Chesapeake Bay Clean Up; Proposed Budget Puts Drinking Water Sources At-Risk for 13 Million Bay Residents</a>
							<span class="post-date">March 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/16/rep-harris-praises-president-trumps-proposed-budget-lauds-defense-increases-vows-to-protect-chesapeake/">Rep. Harris Praises  President Trump&#8217;s Proposed Budget; Lauds Defense Increases, Vows to Protect Chesapeake</a>
							<span class="post-date">March 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/16/nominees-sought-for-31st-annual-harfords-most-beautiful-people-awards/">Nominees Sought for 31st Annual Harford’s Most Beautiful People Awards</a>
							<span class="post-date">March 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/14/c-milton-wright-students-kick-butts-action-urged-to-protect-kids-from-candy-flavored-tobacco-products/">C. Milton Wright Students &#8220;Kick Butts&#8221; &#8211; Action Urged to Protect Kids from Candy-Flavored Tobacco Products</a>
							<span class="post-date">March 14, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/14/harford-county-council-adopts-pro-business-pro-green-energy-legislation-launching-commercial-pace/">Harford County Council Adopts Pro-Business, Pro-Green Energy Legislation Launching Commercial PACE</a>
							<span class="post-date">March 14, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/14/harford-county-public-schools-earns-national-recognition-for-financial-reporting-and-budget-presentation/">Harford County Public Schools Earns National Recognition for Financial Reporting and Budget Presentation</a>
							<span class="post-date">March 14, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/14/city-of-aberdeen-receives-aa-bond-rating/">City of Aberdeen Receives AA+ Bond Rating</a>
							<span class="post-date">March 14, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/13/new-mothers-mobile-home-torched-in-edgewood-bel-air-homeowners-alerted-to-fire-by-service-dog/">New Mother&#8217;s Mobile Home Torched in Edgewood; Bel Air Homeowners Alerted to Fire by Service Dog</a>
							<span class="post-date">March 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/13/harford-county-prepares-for-first-winter-storm-of-2017/">Harford County Prepares for First Winter Storm of 2017</a>
							<span class="post-date">March 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/13/economic-and-health-impacts-of-fracking-to-be-discussed-at-hcc-forum/">Economic and Health Impacts of Fracking to be Discussed at HCC Forum</a>
							<span class="post-date">March 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/03/13/harford-county-flag-lowered-for-dennis-devoe-whiteford-fire-company-member-lost-in-line-of-duty-in-pa/">Harford County Flag Lowered for Dennis DeVoe; Whiteford Fire Company Member Lost in Line of Duty in PA</a>
							<span class="post-date">March 13, 2017</span>
						</li>
				</ul>
		</div></section>		</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="footer-widgets-1 widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(59)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>
		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="footer-widgets-2 widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="footer-widgets-3 widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap"><iframe src="https://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fdaggerpress&#038;width=300&#038;height=300&#038;colorscheme=light&#038;show_faces=true&#038;stream=false&#038;show_border=true&#038;header=false&#038;force_wall=false" scrolling="no" frameborder="0" style="border: none; overflow: hidden; width: 300px;  height: 300px; background: #fff"></iframe></div></section>
</div></div></div><footer class="site-footer" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer><script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type="text/javascript">
//<![CDATA[
var si_captcha_styles = "\
<!-- begin SI CAPTCHA Anti-Spam - comment form style -->\
<style type='text/css'>\
div#captchaImgDiv { display:block; }\
.captchaSizeDivSmall { width:175px; height:45px; padding-top:10px; }\
.captchaSizeDivLarge { width:250px; height:60px; padding-top:10px; }\
img#si_image_com,#si_image_reg,#si_image_log,#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }\
.captchaImgRefresh { border-style:none; margin:0; vertical-align:bottom; }\
div#captchaInputDiv { display:block; padding-top:15px; padding-bottom:5px; }\
label#captcha_code_label { margin:0; }\
input#captcha_code { width:65px; }\
</style>\
<!-- end SI CAPTCHA Anti-Spam - comment form style -->\
";
jQuery(document).ready(function($) {
$('head').append(si_captcha_styles);
});
//]]>
</script>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2017\/03\/16\/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time\/":108948};
		window.WPCOM_jetpack = true;
				window.WPCOM_site_ID = 2163858;
			</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
		<div id="fb-root"></div><script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
		<script type="text/javascript">
			jQuery( document ).ready( function() {
			    jQuery.getScript( '//platform.linkedin.com/in.js?async=true', function success() {
			        IN.init();
			    });
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);
				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/03/16/dagger-movie-night-beauty-and-the-beast-stale-and-old-as-time/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=3.1.8'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-plugins.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.daggerpress.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.2.1'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201712'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=4.4.8'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=4.4.8'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=3.5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=3.5.4'></script>
		<iframe src='http://widgets.wp.com/likes/master.html?ver=20141028#ver=20141028&amp;mp6=1' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script type='text/javascript' src='http://stats.wp.com/e-201712.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.5.4',blog:'2163858',post:'108948',tz:'-4',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '108948' ]);
</script>
</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Page Caching using disk: enhanced

 Served from: daggerpress.com @ 2017-03-19 21:39:43 by W3 Total Cache -->