<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//www.daggerpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly Comments Feed" href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.3' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' async src='http://www.daggerpress.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F11%2F16%2Fdagger-movie-night-justice-league-baby-ugly%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F11%2F16%2Fdagger-movie-night-justice-league-baby-ugly%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<!-- Genesis Advanced SEO Open Graph -->
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="article:section" content="Arts" />
<meta property="article:published_time" content="2017-11-16 20:18:15" />
<meta property="article:modified_time" content="2017-11-17 07:45:54" />
<meta property="og:updated_time" content="2017-11-17 07:45:54" />
<meta property="og:title" content="Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly" />
<meta property="og:description" content="Every film is someone’s baby, even if it’s a baby manufactured in a lab by committee. It is first desired, then conceptualized, then conceived; it’s carried and then born, and placed in the hands of" />
<meta property="og:url" content="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" />
<meta property="og:image:url" content="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="462" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:title" content="Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly" />
<meta property="twitter:description" content="Every film is someone’s baby, even if it’s a baby manufactured in a lab by committee. It is first desired, then conceptualized, then conceived; it’s carried and then born, and placed in the hands of" />
<meta property="twitter:image" content="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg" />
<!-- End Genesis Advanced SEO Open Graph -->
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #999999 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 19px; padding: 10px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #666666 !important; border-color: #ffffff !important; color: #ffffff !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #666666 !important; }</style><script type="text/javascript" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1510922961"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
<style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly" />
<meta property="og:url" content="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" />
<meta property="og:description" content="Every film is someone’s baby, even if it’s a baby manufactured in a lab by committee. It is first desired, then conceptualized, then conceived; it’s carried and then born, and placed in the hands o…" />
<meta property="article:published_time" content="2017-11-17T01:18:15+00:00" />
<meta property="article:modified_time" content="2017-11-17T12:45:54+00:00" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="462" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<!-- BEGIN GADWP v5.1.1.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<style type="text/css" id="wp-custom-css">
				@import  "http://fonts.googleapis.com/css?family=Droid+Sans";

/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/* Import Fonts
------------------------------------------------------------ */
.entry-title {
	font-size: 3.2rem;
	font-weight: 800;
}

.after-entry .widget-title, .archive-title, .comments-title, .widget .entry-title {
	font-size: 1.5rem;
}

.title-area {
	float: left;
	padding: 0;
	width: 302px;
}

.header-image .site-title a {
	background-color: none;
	max-width: 302px;
	min-height: 80px;
	padding: 0;
}

.site-header .widget-area {
	float: right;
	width: 728px;
}

.breadcrumb {
	font-size: 1.2rem;
}

@media only screen and (max-width: 728px) {
	.title-area {
		width: 100%;
	}
	
	.site-header .widget-area {
		width: 100%;
	}
}

body {
	font-family: 'Droid Sans', sans-serif;
}

blockquote, blockquote::before {
	color: #555;
}			</style>
		</head>
<body class="post-template-default single single-post postid-110629 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url"><span itemprop="name">About The Dagger</span></a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url"><span itemprop="name">Terms of Service</span></a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><div class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/" itemprop="url"><span itemprop="name">Sirens</span></a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/question-2/" itemprop="url"><span itemprop="name">Big Q</span></a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/food/" itemprop="url"><span itemprop="name">Health/Food</span></a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/pop-culture/" itemprop="url"><span itemprop="name">A&#038;E</span></a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/balls/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar" itemprop="url"><span itemprop="name">Events</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly</div><article class="post-110629 post type-post status-publish format-standard has-post-thumbnail category-pop-culture category-movies-pop-culture tag-amy-adams tag-ben-affleck tag-ezra-miller tag-gal-gadot tag-henry-cavill tag-jason-momoa tag-justice-league tag-movie tag-new tag-review tag-theater tag-zack-snyder entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-11-16T20:18:15+00:00">November 16, 2017</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.daggerpress.com/author/erik-kristopher-myers/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Erik Kristopher Myers</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
<meta itemprop="url" content="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg">
<meta itemprop="width" content="300">
<meta itemprop="height" content="462">
</span>
<p><a href="http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg"><img class="alignleft wp-image-110627 size-medium" src="http://www.daggerpress.com/wp-content/uploads/poster-justice-league-195x300.jpg" alt="" width="195" height="300" srcset="http://www.daggerpress.com/wp-content/uploads/poster-justice-league-195x300.jpg 195w, http://www.daggerpress.com/wp-content/uploads/poster-justice-league.jpg 300w" sizes="(max-width: 195px) 100vw, 195px" /></a>Every film is someone’s baby, even if it’s a baby manufactured in a lab by committee. It is first desired, then conceptualized, then conceived; it’s carried and then born, and placed in the hands of caregivers – the parents, pediatricians, teachers and child care providers – who in turn endeavor to give it a healthy life. If there’s one thing we can all agree on, it’s that no one should ever intentionally harm an infant, and one should certainly never do something as cruel as, say, punch one in the face.</p>
<p>But I’m going to punch this baby. I’m going to break its nose and its crush its skull. I’m going to murder this baby because it’s ugly, and it screams and never shuts up. It pisses on you when you try to change its diaper; it shits on you when you try to give it a bath. When it smiles, it looks like a rotting pumpkin, and when it laughs, the laugh is a braying, piercing sound that drives home a migraine with the cool efficiency of an icepick through the temple. When it throws up (often), it’s always on some area of carpet that you can never avoid stepping in for the rest of your life, and no matter how hard you try, the smell never comes out; thus, you’re destined to keep stepping in it, and having to go to the bathroom to try to scrub off the clinging, lemony smell of milk vomit. The stain just sits there, staring back at you, never going away, and making you hate the baby even more, until all you can do is think about how much it cost, both in terms of time and in money, to bring this horrible thing into the world, and wishing it had strangled on its own umbilical cord. And it almost did. <em>It almost did!</em></p>
<p>Worst of all, this baby is fucking boring. When it stands up on its fat, stupid baby legs and dances for you, you want to throw something at it and knock it on its ass and delight in its pain; anything, anything at all to provide some comedy. But no, there it is: this putrid little pink lump, a tumor in a spandex onesie, screaming and shitting and living. It will always be here, because not one person responsible for its life made a single decision that made any sense &#8212; like, say, to ensure it didn’t turn into a repulsive and thoroughly unlikeable creature with absolutely no redeeming qualities whatsoever. But you just had to have that baby, didn’t you? You just had to have it, because everyone else was having one, and then two, and then on and on. It was fashionable to have this baby. It was THE THING TO DO. If you keep having them, it’s a SHARED UNIVERSE. And now the only way to silence the shrieking and to stop your home from smelling like the inside of someone’s dead asshole, is to stop feeding it, stop spending your money on it, and let it die. Let it shrivel. Let it turn into a moldering little husk to dry up and flake away once the worms and maggots and beetles have stopped feasting on its emaciated corpse.</p>
<p>This baby is named “Justice League,” and it is in desperate need of a quick death rather than the slow, protracted one audiences have endured since “Man of Steel” forced a diaper blow-out all over movie screens back in 2013. This latest installment is the fifth child in a dysfunctional family conceived by a patriarchy of shallow bean counters who can rock a graph but neither learned when to wear a condom, or when to pull out. We can all argue whether it’s director Zack Snyder’s misguided parenting, or the impulsive ME TOO! aspect of trying to artificially construct a legacy franchise of interconnected films simply because their rivals at Marvel Studios are doing so with unparalleled success. “Look, their house is bigger than ours! They have a nicer kitchen! And everyone just loves their kids! LET’S MAKE BABIES, TOO!” The problem is, no one bothered to figure out what made those other kids so adorable, because Warner Brothers is too busy outfitting their brood in garish Adult Baby Clothes that shoot a Stupid Parent beacon directly into space to warn the aliens that we’re still not ready for their technology yet.</p>
<p>Who do we fault for this unholy genetic mutation? Do we blame Snyder, or foster parent Joss Whedon (who was brought onboard late in the game to reshoot a sizeable portion of what was a notoriously troubled production)? Or do we blame the executives at Warner Brothers, who, in owning the entire DC Comics universe, ejaculated too quickly at the sight of the folks at Marvel taking their time to make sweet, sweet love and produce a relatively bright, happy, vibrant stock? Wherever you point the finger, this rotten assembly of ugly kids are dressed up in mismatched, conflicting colors: neither fun nor studious; tucked and buttoned with great care, while simultaneously creased and rumpled. Their teeth are brushed but their unwashed hair is sticking straight up. Any attention to detail is undermined by haste and compression and urgency. LOOK AT OUR KIDS! PAY MONEY TO WATCH OUR KIDS PLAY! JUST DON’T POINT AND LAUGH WHEN THEY KEEP FALLING ON THEIR FACES BECAUSE WE PUT THEIR SHOES ON THE WRONG FEET.</p>
<p><a href="http://www.daggerpress.com/wp-content/uploads/justice-league-02.jpg"><img class="alignright size-medium wp-image-110626" src="http://www.daggerpress.com/wp-content/uploads/justice-league-02-300x200.jpg" alt="" width="300" height="200" srcset="http://www.daggerpress.com/wp-content/uploads/justice-league-02-300x200.jpg 300w, http://www.daggerpress.com/wp-content/uploads/justice-league-02-768x512.jpg 768w, http://www.daggerpress.com/wp-content/uploads/justice-league-02-1024x683.jpg 1024w, http://www.daggerpress.com/wp-content/uploads/justice-league-02.jpg 1152w" sizes="(max-width: 300px) 100vw, 300px" /></a>“Justice League” is a hyperactive child fed nothing but Pop Rocks and Soda. It can’t calm down, it can’t sit still, and it refuses to do what we want it to do. It’s ADD-addled and spins itself in frenzied circles until it collapses on the floor, unable to move; then, after an interminable stretch during which we’re staring at its chest and hoping it’s stopped breathing, it gets up again, inhales another bag of Skittles, and then spins around until it ruptures day-glow, sugary diarrhea all over the couch. It keeps shrieking, trying to make its pain yours because it isn’t mature enough to articulate its thoughts. And how can it? You can’t blame something for being inherently unable to communicate what it wants; but then you realize it’s the byproduct of self-absorbed stage parents who were more concerned with how their success was perceived than whether their child ever learned to use a knife and fork instead of eating their mashed potatoes with sticky, booger-crusted fingers.</p>
<p>See, the thing is, we’re not just talking about bad movies, here. There are two greater issues at play. The first is the imminent death of the cinematic experience: a revolution of apathy ushered in by a wave of competing technology, including, but not limited to, professional grade home theater systems, portable media, and an unprecedented glut of competing product. In a year in which ticket sales are hitting new lows, and when those who still venture to the local multiplex can’t shut up or get off their cell phones during the movie, it’s no wonder that the entire industry is terrified. Just last week, 20th Century Fox was in talks to sell to Disney. Anyone who fails to grasp the troubling implications of a media giant looking to board up their windows against the coming storm is probably a fan of movies like this, or “Transformers,” or endless remakes and soft reboots and every other Lowest Common Denominator Product the studios are churning out for the people of Walmart. These films are killing the industry with huge openings and sharp drop-offs. It’s all McDonalds, all the time, and the non-stop production of cinematic fast food is silencing bold and innovative voices trying to do more than to pander to some idiot tweeting through the entire film. LOL @AQUAMAN IZ SOOO HAWT ROFLMAO #JUSTFUCKINGKILLME</p>
<p>The second issue here is that the entire DC Universe pantheon of heroes – Superman, Batman, Wonder Woman, and all the others – are an important component of our shared cultural heritage. We’re not just talking about “superheroes,” or Kids’ Stuff; these characters, along with Spider-Man and all the Marvel roster, represent our latter day mythology. You don’t have to like it, but it’s undeniable, much like the fact that the Earth is round and “Justice League” sucks. These stories are told the same way as the sagas of old, and feature modern reinterpretations of Hercules, Beowulf, or that dude with the holes in his hands. These are tales meant to inspire children and adults alike, and to reflect our social needs in a manner that is allegorical, and therefore more easily deconstructed and understood for what the components are and what they represent. This stuff is meant to teach us about ourselves and one another, goofy costumes notwithstanding.</p>
<p>And that’s what makes it so maddening to watch iconic characters fully-realized for the first time in a way they never could before, and to see them squandered, tainted, and utterly wasted on an entire generation who doesn’t know any better and probably doesn’t care. In an age in which we’re spoiled on long-form television with high production values and episodic structure, we forget that once upon a time, comic books filled that same purpose. It’s only now, with the relatively recent advances in special effects, that we can suspend disbelief and believe that Superman (Henry Cavill) can fly, or the Flash (Ezra Miller) can speed as quick as lightning, or that Cyborg (Ray Fisher) can convincingly look like a bad cartoon in every scene he’s in no wait a minute no never mind, the special effects and digital compositing in this film are absolute garbage, so forget what I said before. When trying to get your kid on the bus with only five minutes to spare, you don’t dress it, put on its coat, and take it outside, only to then take it back inside to change its outfit because you saw how your neighbor dressed their kid differently. Eventually the bus is going to show up, and you’ll be out of time; and that’s exactly what happened with “Justice League.” It’s a rush job, a two-hour Do-Over, and it shows, in terms of narrative construction, and in terms of its visuals.</p>
<p><a href="http://www.daggerpress.com/wp-content/uploads/justice-league-01.jpg"><img class="alignleft size-medium wp-image-110628" src="http://www.daggerpress.com/wp-content/uploads/justice-league-01-300x168.jpg" alt="" width="300" height="168" srcset="http://www.daggerpress.com/wp-content/uploads/justice-league-01-300x168.jpg 300w, http://www.daggerpress.com/wp-content/uploads/justice-league-01-768x429.jpg 768w, http://www.daggerpress.com/wp-content/uploads/justice-league-01-1024x572.jpg 1024w, http://www.daggerpress.com/wp-content/uploads/justice-league-01.jpg 1152w" sizes="(max-width: 300px) 100vw, 300px" /></a>“Justice League” is a film that dislikes its characters and attempts to redefine them for no reason whatsoever beyond trying to be both different and the same as Marvel. It’s constantly backtracking on the established continuity of its fledgling universe, rendering its heroes schizophrenic and the mood hovering somewhere between Manic and Depressed. Batman (Ben Affleck) still looks like a beer-bellied gorilla, but he’s now mourning the loss of Superman, despite the fact that when we last saw him, the Dark Knight was obsessed with murdering his frenemy in a variety of ways that can only be accomplished through the practice of throwing and then dragging tires. Meanwhile, the Man of Steel is resurrected from death in an unintentionally hilarious way (he’s dumped out of his coffin and floats on his back in a Kryptonian brine while the other heroes just sort of stand there and look at him). His unmoving corpse is made retroactively exciting and positively charismatic in hindsight once the reanimated version shows up in the third act, fully suited-up and ready to fight, and reintroduced with all the dramatic flair of a four year-old’s dance recital. It doesn’t help matters that, due to aggressive reshoots during which time Cavill was sporting a thick mustache for the latest “Mission: Impossible” film, the “Justice League” animators were forced to actually paint out his facial hair. This Superman has a mouth so utterly weird that it becomes the most interesting part of a film screaming at you to pay attention to it because it’s terrified that you won’t otherwise.</p>
<p>However, Wonder Woman (Gal Gadot) still sounds like she’s doing a dramatic reading of the menu at Taco Bell, and we’re given frequent shots of her ass, so that much remains consistent, at least. No Uncanny Valleys there – just an opportunity to fetishize and Male Gaze our way across the Uncanny Valley of Trump’s America.</p>
<p>But let’s be fair: the ladies get their own large-breasted, long-haired, human-shaped object, too! Meet Aquaman (Jason Mamoa), a superhero everyone has made fun of for decades. Even the film itself makes a point to laugh at him before we can (“I hear you talk to fish”), without anticipating that the transformation of the character from a WASP-y eugenics template in spandex into Dimebag Darrell is so desperate in its attempts to be EXTREME that the only thing missing is a bottle of Mountain Dew or Jolt Cola. He might roar like James Hetfield, but he’s one hundred percent Nickelback. The fact that he BOO-YAs and YAY-YAHs his way through the interminable runtime makes you wish he’d accidentally cut his own throat with that giant turkey fork he carries around. At least then we’d have a story, because without it, we literally don’t have one. It’s two very long hours of XBOX 360-era cutscenes in which an embarrassing special effect (Ciaran Hinds) is trying to collect magic boxes to do something for some reason. Who knows? Who cares? Someone shut that baby up, because it won’t stop screaming.</p>
<p>And make no mistake, “Justice League” is an ugly, ugly baby indeed. A lot of sperm from a roster of reasonably desirable male candidates has been stirred together to create this misbegotten, genetically stunted infant with a voice like nails on a chalkboard and a face even a mother could be ashamed of. The absolute best thing audiences could possibly do would be to find the nearest Pro Life protestor, grab their sign, and impale them through the heart with it. Sometimes, dead is better. Just ask Superman, whose best scenes feature him as a corpse.</p>
<p>Directed by Zack Snyder<br />
Written by Chris Terrio, Joss Whedon<br />
Rating PG-13 for sequences of sci-fi violence and action</p>
<p><iframe src="https://www.youtube.com/embed/r9-DM9uBtVI" width="427" height="240" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" data-text="Dagger Movie Night: “Justice League” -- Your Baby is Ugly"  >Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F11%2F16%2Fdagger-movie-night-justice-league-baby-ugly%2F&#038;media=http%3A%2F%2Fwww.daggerpress.com%2Fwp-content%2Fuploads%2Fposter-justice-league.jpg&#038;description=Dagger%20Movie%20Night%3A%20%E2%80%9CJustice%20League%E2%80%9D%20--%20Your%20Baby%20is%20Ugly" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-110629-5a0edad1a6b97' data-src='https://widgets.wp.com/likes/#blog_id=2163858&amp;post_id=110629&amp;origin=www.daggerpress.com&amp;obj_id=2163858-110629-5a0edad1a6b97' data-name='like-post-frame-2163858-110629-5a0edad1a6b97'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><meta itemprop="dateModified" content="2017-11-17T07:45:54+00:00" /><meta itemprop="mainEntityOfPage" content="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" /></div><footer class="entry-footer"></footer></article>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/16/dagger-movie-night-justice-league-baby-ugly/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.daggerpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>


<div class="si_captcha_small"><img id="si_image_com" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix=dMgvVpLnc64ICst8" width="132" height="45" alt="CAPTCHA" title="CAPTCHA" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="dMgvVpLnc64ICst8" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix='); return false;">
      <img class="si_captcha_refresh" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh" onclick="this.blur();" /></a>
	</div>
	</div>

<p id="si_captcha_code_p">
<input id="si_captcha_code" name="si_captcha_code" type="text" />
<label for="si_captcha_code" >CAPTCHA Code</label><span class="required"> *</span>
</p>

<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='110629' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="717df99f03" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="65"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.daggerpress.com/" role="search"><meta itemprop="target" content="http://www.daggerpress.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Thank you for writing this.  We are in the same situation and have contacted many congress members about this,&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404216" title="Retired | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>Retired</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Even better, if we did get drawn into a large scale war and a draft was reinstated, those same 18&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/maryland-public-health-groups-urge-lawmakers-raise-states-tobacco-sales-age-21/#comment-404215" title="SoulCrusher | Maryland Public Health Groups Urge Lawmakers to Raise States Tobacco Sales Age to 21"><strong>SoulCrusher</strong> | Maryland Public Health Groups Urge Lawmakers to Raise States Tobacco Sales Age to 21</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;This bill is also terrible for seniors. Taxpayers will no longer be able to deduct medical expenses under the legislation.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404214" title="This Legislation is Terrible for Seniors | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>This Legislation is Terrible for Seniors</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Why would you support a bill that will raise taxes for middle Americans by removing the state and local tax&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404212" title="Diane | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>Diane</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It's amazing that you can't buy a beer at 18, and now they want to prevent you from buying cigarettes&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/maryland-public-health-groups-urge-lawmakers-raise-states-tobacco-sales-age-21/#comment-404211" title="Pavel314 | Maryland Public Health Groups Urge Lawmakers to Raise States Tobacco Sales Age to 21"><strong>Pavel314</strong> | Maryland Public Health Groups Urge Lawmakers to Raise States Tobacco Sales Age to 21</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Yea I'm curious to see how many Trump supporters will be cool with a tax increase with the "biggest tax&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404210" title="Cortexiphan | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>Cortexiphan</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I am not sure your constituents will enjoy the tax increase you voted on them. Now our state taxes won’t&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404208" title="Cdev | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>Cdev</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It is wrong to bulldoze lower income areas of Edgewood, if the less fortunate need help..............Harford Count is certainly able&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/13/edgewood-redevelopment-study-presented-november-15/#comment-404207" title="Hunter | Edgewood Redevelopment Study to be Presented November 15"><strong>Hunter</strong> | Edgewood Redevelopment Study to be Presented November 15</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Raising taxes on the middle class while taking away veterans healthcare to give his corporate donors more money for their&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/#comment-404206" title="Dr No needs to go | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;"><strong>Dr No needs to go</strong> | Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;So, what is your fascination with "Jesse Bane's Big Blue Balls"?&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/10/30/aberdeen-rape-suspect-apprehended-baltimore/#comment-404201" title="SoulCrusher | Aberdeen Rape Suspect Apprehended in Baltimore"><strong>SoulCrusher</strong> | Aberdeen Rape Suspect Apprehended in Baltimore</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You know I'm not black.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/10/30/aberdeen-rape-suspect-apprehended-baltimore/#comment-404200" title="SoulCrusher | Aberdeen Rape Suspect Apprehended in Baltimore"><strong>SoulCrusher</strong> | Aberdeen Rape Suspect Apprehended in Baltimore</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;District B has become more and more residential and business.  The area around the development of commercial at Rt&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/15/friends-harford-2017-comprehensive-zoning-review-wrap/#comment-404199" title="jean | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up"><strong>jean</strong> | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Could be Obama's boy or Freddy Gray's cousin...just sayin..&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/10/30/aberdeen-rape-suspect-apprehended-baltimore/#comment-404198" title="Jesse Bane's Big Blue Balls | Aberdeen Rape Suspect Apprehended in Baltimore"><strong>Jesse Bane's Big Blue Balls</strong> | Aberdeen Rape Suspect Apprehended in Baltimore</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;That's Robin egg blue. Its damn near pretty!&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/12/aberdeen-receives-first-little-free-library-swan-meadows-gets-brush-kindness-humanity-susquehannas-volunteers/#comment-404196" title="Bluejay | Aberdeen Receives First Little Free Library; Swan Meadows Gets Brush With Kindness from Habitat Susquehanna"><strong>Bluejay</strong> | Aberdeen Receives First Little Free Library; Swan Meadows Gets Brush With Kindness from Habitat Susquehanna</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I bet Havre De Grace can't wait for that new high school!! Whoo!!      What better&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/15/friends-harford-2017-comprehensive-zoning-review-wrap/#comment-404195" title="The Onedurer | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up"><strong>The Onedurer</strong> | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Looks like all charges were dismissed&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/05/08/drunk-driver-charged-in-fatal-aberdeen-hit-45-yr-old-woman-killed/#comment-404194" title="Sword of Light | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed"><strong>Sword of Light</strong> | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;What is current status of case? Was he sentenced??&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/05/08/drunk-driver-charged-in-fatal-aberdeen-hit-45-yr-old-woman-killed/#comment-404193" title="D Melendez | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed"><strong>D Melendez</strong> | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Is Jesse Bane still the Bel Air Police Chief?&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/01/new-harford-democratic-club-discusses-affordable-care-act-state-healthcare-representative/#comment-404192" title="Jesse Bane's Big Blue Balls | New Harford Democratic Club Discusses Affordable Care Act with State Healthcare Representative"><strong>Jesse Bane's Big Blue Balls</strong> | New Harford Democratic Club Discusses Affordable Care Act with State Healthcare Representative</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Mayor McGrady is dreamy!  I love the way he leads the Council meetings.  He is so hot!!!&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/09/mayor-mcgrady-goal-since-day-council-elected-see-greater-use-ripken-stadium/#comment-404191" title="Jeannine Hoy | Mayor McGrady: “The Goal, Since the Day this Council was Elected, is to See Greater Use of Ripken Stadium”"><strong>Jeannine Hoy</strong> | Mayor McGrady: “The Goal, Since the Day this Council was Elected, is to See Greater Use of Ripken Stadium”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;SoulCrusher??&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/10/30/aberdeen-rape-suspect-apprehended-baltimore/#comment-404190" title="Jesse Bane's Big Blue Balls | Aberdeen Rape Suspect Apprehended in Baltimore"><strong>Jesse Bane's Big Blue Balls</strong> | Aberdeen Rape Suspect Apprehended in Baltimore</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;That is a hideous shade of blue.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/12/aberdeen-receives-first-little-free-library-swan-meadows-gets-brush-kindness-humanity-susquehannas-volunteers/#comment-404189" title="Jeannine Hoy | Aberdeen Receives First Little Free Library; Swan Meadows Gets Brush With Kindness from Habitat Susquehanna"><strong>Jeannine Hoy</strong> | Aberdeen Receives First Little Free Library; Swan Meadows Gets Brush With Kindness from Habitat Susquehanna</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Can you contact me Shibbs ??&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/05/08/drunk-driver-charged-in-fatal-aberdeen-hit-45-yr-old-woman-killed/#comment-404187" title="kelli | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed"><strong>kelli</strong> | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Brad is still driving. ??  How did he dodge this bullet,  most people cant lie this good to&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/05/08/drunk-driver-charged-in-fatal-aberdeen-hit-45-yr-old-woman-killed/#comment-404186" title="kelli | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed"><strong>kelli</strong> | Drunk Driver Charged in Fatal Aberdeen Hit &#038; Run; 45-Yr-Old Woman Killed</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You can really see the people who are clueless on zoning, they still have their dumb ass big business Klien&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/15/friends-harford-2017-comprehensive-zoning-review-wrap/#comment-404184" title="Harford Republican | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up"><strong>Harford Republican</strong> | Friends of Harford 2017 Comprehensive Zoning Review Wrap Up</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Could have had it in Aberdeen and gave away free drugs from the evidence room and drop off box!!&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/11/13/harford-county-encourages-family-dinnertime-conversations-drugs-alcohol-night-conversation/#comment-404183" title="drugs in the DEEN!! | Harford County Encourages Family Dinnertime Conversations about Drugs and Alcohol on a “Night of Conversation”"><strong>drugs in the DEEN!!</strong> | Harford County Encourages Family Dinnertime Conversations about Drugs and Alcohol on a “Night of Conversation”</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section>
<section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
					<li>
				<a href="http://www.daggerpress.com/2017/11/17/woman-2-young-children-victims-vehicle-shooting-attack/">Woman and 2 Young Children Victims of Vehicle Shooting Attack</a>
							<span class="post-date">November 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/16/dagger-movie-night-justice-league-baby-ugly/">Dagger Movie Night: “Justice League” &#8212; Your Baby is Ugly</a>
							<span class="post-date">November 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/16/harford-county-launches-harford-buy-campaign-encourage-job-creation-economic-growth/">Harford County Launches “Harford Has It: Buy In” Campaign to Encourage Job Creation, Economic Growth</a>
							<span class="post-date">November 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/16/maryland-public-health-groups-urge-lawmakers-raise-states-tobacco-sales-age-21/">Maryland Public Health Groups Urge Lawmakers to Raise States Tobacco Sales Age to 21</a>
							<span class="post-date">November 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/16/rep-harris-proud-support-largest-tax-cut-american-history/">Rep. Harris: Proud to Support &#8220;Largest Tax Cut in American History&#8221;</a>
							<span class="post-date">November 16, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/15/friends-harford-2017-comprehensive-zoning-review-wrap/">Friends of Harford 2017 Comprehensive Zoning Review Wrap Up</a>
							<span class="post-date">November 15, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/15/hays-heighe-house-presents-equestrian-journalism-award-family-tv-sports-broadcaster-jim-mckay/">Hays-Heighe House Presents Equestrian Journalism Award to the Family of TV Sports Broadcaster Jim McKay</a>
							<span class="post-date">November 15, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/15/naughton-named-dean-community-education-harford-community-college/">Naughton Named Dean for Community Education at Harford Community College</a>
							<span class="post-date">November 15, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/13/harford-county-encourages-family-dinnertime-conversations-drugs-alcohol-night-conversation/">Harford County Encourages Family Dinnertime Conversations about Drugs and Alcohol on a “Night of Conversation”</a>
							<span class="post-date">November 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/13/edgewood-redevelopment-study-presented-november-15/">Edgewood Redevelopment Study to be Presented November 15</a>
							<span class="post-date">November 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/13/boys-girls-clubs-harford-cecil-county-celebrate-successful-valley-haunted/">Boys &#038; Girls Clubs of Harford and Cecil County Celebrate Successful &#8220;Valley of the Haunted&#8221;</a>
							<span class="post-date">November 13, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/12/former-army-official-contractor-sentenced-bribery-scheme-involving-contracts-apg/">Former Army Official and Contractor Sentenced in Bribery Scheme Involving Contracts at APG</a>
							<span class="post-date">November 12, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/12/tilley-president-harford-county-sheriffs-foundation-announces-candidacy-house-delegates-district-34b/">Tilley, President of Harford County Sheriff’s Foundation, Announces Candidacy for House of Delegates District 34B</a>
							<span class="post-date">November 12, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/12/aberdeen-receives-first-little-free-library-swan-meadows-gets-brush-kindness-humanity-susquehannas-volunteers/">Aberdeen Receives First Little Free Library; Swan Meadows Gets Brush With Kindness from Habitat Susquehanna</a>
							<span class="post-date">November 12, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/12/harford-county-collects-nearly-1300-pounds-unused-medicines-october-prescription-drug-take-back-day/">Harford County Collects Nearly 1,300 Pounds of Unused Medicines at October Prescription Drug Take Back Day</a>
							<span class="post-date">November 12, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/10/dagger-movie-night-murder-orient-express-another-stab-agatha-christie-2/">Dagger Movie Night: “Murder on the Orient Express” &#8212; Another Stab at Agatha Christie</a>
							<span class="post-date">November 10, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/09/mayor-mcgrady-goal-since-day-council-elected-see-greater-use-ripken-stadium/">Mayor McGrady: “The Goal, Since the Day this Council was Elected, is to See Greater Use of Ripken Stadium”</a>
							<span class="post-date">November 9, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/09/chmielewski-richards-win-town-bel-air-commissioners-seats/">Chmielewski and Richards Win Town of Bel Air Commissioners Seats</a>
							<span class="post-date">November 9, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/08/owner-defense-contracting-firm-sentenced-paying-bribes-civilian-employee-apg/">Owner of Defense Contracting Firm Sentenced for Paying Bribes to Civilian Employee at APG</a>
							<span class="post-date">November 8, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/11/08/sgt-alfred-b-hilton-bridge-dedicated-harford-countys-medal-honor-recipient/">Sgt. Alfred B. Hilton Bridge Dedicated to Harford County&#8217;s Only Medal of Honor Recipient</a>
							<span class="post-date">November 8, 2017</span>
						</li>
				</ul>
		</div></section>
		</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2017/11/'> November 2017 &nbsp;(30)</option>
	<option value='http://www.daggerpress.com/2017/10/'> October 2017 &nbsp;(57)</option>
	<option value='http://www.daggerpress.com/2017/09/'> September 2017 &nbsp;(42)</option>
	<option value='http://www.daggerpress.com/2017/08/'> August 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/07/'> July 2017 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2017/06/'> June 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/05/'> May 2017 &nbsp;(84)</option>
	<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>
		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/daggerpress" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/daggerpress"><a href="https://www.facebook.com/daggerpress"></a></blockquote></div>
		</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer>	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2017\/11\/16\/dagger-movie-night-justice-league-baby-ugly\/":110629};
	</script>
<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/11/16/dagger-movie-night-justice-league-baby-ugly/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_ulike_params = {"ajax_url":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","counter_selector":".count-box","button_selector":".wp_ulike_btn","general_selector":".wp_ulike_general_class","button_type":"image","notifications":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=2.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.daggerpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201746'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=5.3'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=5.3'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=5.3'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=20170629#ver=20170629' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201746.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.3',blog:'2163858',post:'110629',tz:'-5',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '110629' ]);
</script>
</body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced
Fragment Caching 0/0 fragments using disk

 Served from: daggerpress.com @ 2017-11-17 07:49:21 by W3 Total Cache -->