<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat Comments Feed" href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.daggerpress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=3.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.0' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2019%2F12%2F19%2Fmike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2019%2F12%2F19%2Fmike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat" />
<meta property="og:url" content="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" />
<meta property="og:description" content="From the Republic Central Committee of Harford County: Earlier today, the RCCHC submitted our unanimous recommendation to Governor Hogan to appoint Mike Griffith of Bel Air and current RCCHC Chairm…" />
<meta property="article:published_time" content="2019-12-19T22:02:47+00:00" />
<meta property="article:modified_time" content="2019-12-19T22:02:47+00:00" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<!-- BEGIN GADWP v5.1.1.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<style type="text/css" id="wp-custom-css">
				@import  "http://fonts.googleapis.com/css?family=Droid+Sans";

/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/* Import Fonts
------------------------------------------------------------ */
.entry-title {
	font-size: 3.2rem;
	font-weight: 800;
}

.after-entry .widget-title, .archive-title, .comments-title, .widget .entry-title {
	font-size: 1.5rem;
}

.title-area {
	float: left;
	padding: 0;
	width: 302px;
}

.header-image .site-title a {
	background-color: none;
	max-width: 302px;
	min-height: 80px;
	padding: 0;
}

.site-header .widget-area {
	float: right;
	width: 728px;
}

.breadcrumb {
	font-size: 1.2rem;
}

@media only screen and (max-width: 728px) {
	.title-area {
		width: 100%;
	}
	
	.site-header .widget-area {
		width: 100%;
	}
}

body {
	font-family: 'Droid Sans', sans-serif;
}

blockquote, blockquote::before {
	color: #555;
}			</style>
		</head>
<body class="post-template-default single single-post postid-112431 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url"><span itemprop="name">About The Dagger</span></a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url"><span itemprop="name">Terms of Service</span></a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><div class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/" itemprop="url"><span itemprop="name">Sirens</span></a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/category/question-2/" itemprop="url"><span itemprop="name">Big Q</span></a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/" itemprop="url"><span itemprop="name">Health/Food</span></a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/" itemprop="url"><span itemprop="name">A&#038;E</span></a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar" itemprop="url"><span itemprop="name">Events</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/category/local-ink/" itemprop="item"><span itemprop="name">Local</span></a></span> <span aria-label="breadcrumb separator">/</span> Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat</div><article class="post-112431 post type-post status-publish format-standard category-local-ink category-the-dirt entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-12-19T17:02:47-05:00">December 19, 2019</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.daggerpress.com/author/daggernews/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Dagger News Service</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comments">5 Comments</a></span> </p></header><div class="entry-content" itemprop="text"><p>From the Republic Central Committee of Harford County:</p>
<p>Earlier today, the RCCHC submitted our unanimous recommendation to Governor Hogan to appoint Mike Griffith of Bel Air and current RCCHC Chairman, to fill the vacated District 35B Delegate seat in Annapolis. If approved by the Governor, Mike will serve the remainder of Andrew Cassilly&#8217;s term of office. </p>
<p>We want to thank the other applicants for the position, Diane Sengstacke, Jim Welch and Luke Kaczmarek, who interviewed and answered questions from the committee Wednesday evening. All of the applicants were well qualified and ready to serve on very short notice before the start of the 2020 season. </p>
<p>We also wish to acknowledge the service of Delegate Andrew Cassilly to Harford and Cecil counties in District 35B. Andrew is a class act; he represented his constituents well, and will be missed. </p>
<p>Regards, </p>
<p>Jeffery McBride</p>
<p>Member, Republic Central Committee of Harford County</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" data-text="Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat"  >Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2019%2F12%2F19%2Fmike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat%2F&#038;media=http%3A%2F%2F0.gravatar.com%2Favatar%2F9943ada0a4ac662b8adc37ee7819c8c9%3Fs%3D96%26d%3Dmm%26r%3Dg&#038;description=Mike%20Griffith%20Nominated%20to%20Fill%20Cassilly%E2%80%99s%20District%2035B%20Delegate%20Seat" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-112431-5e005e8a38f94' data-src='https://widgets.wp.com/likes/#blog_id=2163858&amp;post_id=112431&amp;origin=www.daggerpress.com&amp;obj_id=2163858-112431-5e005e8a38f94' data-name='like-post-frame-2163858-112431-5e005e8a38f94'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Dagger News Service</span></h4><div class="author-box-content" itemprop="description"><p>Send Us Your News<br />
<a href="mailto:tellus@daggerpress.com">tellus@daggerpress.com</a></p>
</div></section><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-453918">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/218bd57e8b01b90414e9cdbcaf517c03?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/218bd57e8b01b90414e9cdbcaf517c03?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">LMAO</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-12-20T07:31:12-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comment-453918" class="comment-time-link" itemprop="url">December 20, 2019 at 7:31 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>It&#8217;s amazing RCCHC  could find the time with all their posting of childish memes on facebook.		</p>
<div class="wpulike wpulike-default " >
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="453918"
					data-ulike-nonce="465e820192"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?replytocom=453918#respond' data-commentid="453918" data-postid="112431" data-belowelement="comment-453918" data-respondelement="respond" aria-label='Reply to LMAO'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-453925">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/58bc805d6b5ad33c6b2444e3acb48db7?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/58bc805d6b5ad33c6b2444e3acb48db7?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Truth Be Told</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-12-20T08:48:35-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comment-453925" class="comment-time-link" itemprop="url">December 20, 2019 at 8:48 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Who is Mike Griffith&#8230;.Why not David Ryden or his buddy Adam?		</p>
<div class="wpulike wpulike-default " >
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="453925"
					data-ulike-nonce="0aa69f1710"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?replytocom=453925#respond' data-commentid="453925" data-postid="112431" data-belowelement="comment-453925" data-respondelement="respond" aria-label='Reply to Truth Be Told'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment even depth-2" id="comment-453937">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/f700b2842c6249a63d08ee3f41da0fec?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f700b2842c6249a63d08ee3f41da0fec?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Mike Callahan</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-12-20T14:34:21-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comment-453937" class="comment-time-link" itemprop="url">December 20, 2019 at 2:34 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Mike Griffiths  (RCCHC Chairman) call to fame was his managing the  disastrous JD  &#8220;Voter ID&#8221; Russell campaign in  South Harford.for House of Delegates.<br />
 For that failed mission he gets nominated to the House himself!<br />
 Griffith is so far to the right  politically that he makes Trump look like a boy scout!<br />
Take a look at his resume from Red Maryland!<br />
When asked what book he was reading he drew a blank.!</p>
<p><a href="https://redmaryland.com/2018/06/candidate-survey-mike-griffith-for-harford-county-central-committee/" rel="nofollow">https://redmaryland.com/2018/06/candidate-survey-mike-griffith-for-harford-county-central-committee/</a>		</p>
<div class="wpulike wpulike-default " >
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="453937"
					data-ulike-nonce="79a6df7f11"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?replytocom=453937#respond' data-commentid="453937" data-postid="112431" data-belowelement="comment-453937" data-respondelement="respond" aria-label='Reply to Mike Callahan'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-3" id="comment-453946">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/f700b2842c6249a63d08ee3f41da0fec?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f700b2842c6249a63d08ee3f41da0fec?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Mike Callahan</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-12-20T17:10:21-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comment-453946" class="comment-time-link" itemprop="url">December 20, 2019 at 5:10 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>The better qualified  nominee for District 35B is Cecil County Republicans  David Woodruff.!</p>
<p><a href="https://cecilgop.org/cecil-gop-nominates-woodruff-for-delegate-35b-seat" rel="nofollow">https://cecilgop.org/cecil-gop-nominates-woodruff-for-delegate-35b-seat</a></p>
<p><a href="https://redmaryland.com/2018/03/candidate-survey-david-woodruff-cecil-county-central-committee/?fbclid=IwAR2GXMwvIhU74pWnxfwdvLLXLee-m9lFVWdj8vGp98UcsCQXyzj81T2gB7g" rel="nofollow">https://redmaryland.com/2018/03/candidate-survey-david-woodruff-cecil-county-central-committee/?fbclid=IwAR2GXMwvIhU74pWnxfwdvLLXLee-m9lFVWdj8vGp98UcsCQXyzj81T2gB7g</a>		</p>
<div class="wpulike wpulike-default " >
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="453946"
					data-ulike-nonce="acc7cf0991"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?replytocom=453946#respond' data-commentid="453946" data-postid="112431" data-belowelement="comment-453946" data-respondelement="respond" aria-label='Reply to Mike Callahan'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-453938">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/99378beb4be7774fe038874a607e197d?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/99378beb4be7774fe038874a607e197d?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">James</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-12-20T14:43:48-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#comment-453938" class="comment-time-link" itemprop="url">December 20, 2019 at 2:43 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>In breeding at its finest		</p>
<div class="wpulike wpulike-default " >
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="453938"
					data-ulike-nonce="69f44eaae4"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/?replytocom=453938#respond' data-commentid="453938" data-postid="112431" data-belowelement="comment-453938" data-respondelement="respond" aria-label='Reply to James'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ol></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.daggerpress.com/wp-comments-post.php?wpe-comment-post=sp20183cbm0e7" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='112431' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="70979e8052" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="69"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.daggerpress.com/" role="search"><meta itemprop="target" content="http://www.daggerpress.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Let it go. You'll feel better in the morning.  It's unfortunate that when you get frustrated your go-to is&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454069" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Really? Was President Ford a framer of the Constitution? NO. He was wrong. The standard of impeachment is NOT an&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454067" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Again nice try. Did you get a chance to call the Mayor of Chicago and let her know what’s going&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-454066" title="Sorry if the truth hurts | Suspects Taken into Custody for Havre de Grace Assault"><strong>Sorry if the truth hurts</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You seem to have a blind spot or some sort of fixation about "race baiting".  My question is pretty&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-454065" title="Bob | Suspects Taken into Custody for Havre de Grace Assault"><strong>Bob</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;President Gerald Ford nailed it from a practical sense when he said, “An impeachable offense is whatever a majority of&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454063" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Yeah, I remember that BS hitjob too. Cohen folded so you DemoTraitors wouldn't crucify him over tax evasion. Look, you&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454062" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Your ghetto question was not germane to the issue of black on black violence I was speaking of in Chicago&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-454061" title="Sorry if the truth hurts | Suspects Taken into Custody for Havre de Grace Assault"><strong>Sorry if the truth hurts</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"The President, Vice President and all civil Officers of the United States, shall be removed from Office on Impeachment for,&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454058" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;13 in Chicago, 7 in Baltimore shot what a terrible waste. My POV — Fewer guns &amp; more restrictive gun&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-454056" title="Bob | Suspects Taken into Custody for Havre de Grace Assault"><strong>Bob</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Your comment, that you are "certainly not as worldly and intelligent as Bob" made me blush. Interesting, I never really&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454048" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The argument that an impeachable offense has to be a "crime" is a red herring and simply BOGUS!&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454046" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;13 people shot at a party in Chicago over the weekend. All of the victims appeared to be black. Preliminary&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-454045" title="Sorry if the truth hurts | Suspects Taken into Custody for Havre de Grace Assault"><strong>Sorry if the truth hurts</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Didn't cheat? His lawyer is literally sitting in jail as we speak for conspiring with him to cheat.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454041" title="? | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>?</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I just reread my post again. Your response generated concerns that person(s) unknown to me who possessed far greater technical&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454040" title="The real Just for | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>The real Just for</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;He didn't cheat in the 2016 election, but Hillary did. She even BOUGHT the Democratic Primary. All we hear is&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454039" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;As much as you attempt to characterize impeachment as something t isn't, there is no process to unimpeach trump. For&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454035" title="Just the facts | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Just the facts</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Legally Impeached with NO CRIME stated in the Impeachment. There's no such thing. Only a DemoTraitor, like you, would see&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454034" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;There is no such thing as obstruction of Congress. There is obstruction of Justice, but this Congress was never interested&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454020" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Just a reminder for all the haters. In this country we operate under the principle that an individual is innocent&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454015" title="The real Just for | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>The real Just for</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Obstruction of Congress is both illegal and unconstitutional. Trump could defeat both articles of impeachment immediately  by letting Mulvaney&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454014" title="Just the facts | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Just the facts</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;LOL gotta love how the orange turd getting legally impeached suddenly makes every moronic koolaid  drinking republican a Constitutional&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454001" title="LOL | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>LOL</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;By the way, every elected government official and government employee who has taken part in this INQUISITION is guilty of&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-454000" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Really? Please name the codified statute that was included in the Articles of Impeachment. Impeachment only occurs when high crimes&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-453998" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I want somma what crusher is smocking.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-453997" title="Cheech | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Cheech</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Oh he was impeached here was a vote and for once trump received the majority of votes. It was broadcast&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-453996" title="Harford Republican | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Harford Republican</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section>
<section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
											<li>
					<a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/">Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat</a>
											<span class="post-date">December 19, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/19/drunk-driver-arrested-after-crashing-into-aberdeen-police-car/">Drunk Driver Arrested after Crashing into Aberdeen Police Car</a>
											<span class="post-date">December 19, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/">Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a>
											<span class="post-date">December 18, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/06/aberdeen-man-arrested-for-possession-of-child-pornography/">Aberdeen Man Arrested for Possession of Child Pornography</a>
											<span class="post-date">December 6, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/04/delaware-thieves-caught-in-the-act-at-harford-mall/">Delaware Thieves Caught in the Act at Harford Mall</a>
											<span class="post-date">December 4, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/03/republican-central-committee-of-harford-county-seeks-applications-to-fill-del-cassillys-seat/">Republican Central Committee of Harford County Seeks Applications to Fill Del. Cassilly&#8217;s Seat</a>
											<span class="post-date">December 3, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/03/blum-holiday-cheer-and-thanks-despite-christmas-parade-cancellation/">Blum: Holiday Cheer and Thanks, Despite Christmas Parade Cancellation</a>
											<span class="post-date">December 3, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/02/gov-hogan-appoints-del-andrew-cassilly-as-senior-advisor/">Gov. Hogan Appoints Del. Andrew Cassilly as Senior Advisor</a>
											<span class="post-date">December 2, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/26/driver-killed-as-truck-overturns-off-conowingo-dam/">Driver Killed as Truck Overturns Off Conowingo Dam</a>
											<span class="post-date">November 26, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/22/baltimore-man-arrested-in-connection-to-edgewood-murder/">Baltimore Man Arrested in Connection to Edgewood Murder</a>
											<span class="post-date">November 22, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/18/harford-school-superintendent-bulson-to-host-fy21-budget-community-forums/">Harford School Superintendent Bulson to Host FY21 Budget Community Forums</a>
											<span class="post-date">November 18, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/14/bank-teller-arrested-in-connection-to-bel-air-home-invasion/">Bank Teller Arrested in Connection to Bel Air Home Invasion</a>
											<span class="post-date">November 14, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/14/new-harford-democratic-club-calls-for-action-on-proposed-kirwan-funding-formula/">New Harford Democratic Club Calls for Action on Proposed Kirwan Funding Formula</a>
											<span class="post-date">November 14, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/13/fatal-fire-under-investigation-near-havre-de-grace/">Fatal Fire Under Investigation Near Havre de Grace</a>
											<span class="post-date">November 13, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/08/man-under-influence-of-drugs-arrested-at-bel-air-7-eleven/">Man Under Influence of Drugs Arrested at Bel Air 7-Eleven</a>
											<span class="post-date">November 8, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/06/sen-cassilly-new-juvenile-justice-commission-will-look-at-growing-epidemic-of-violent-juvenile-crime/">Sen. Cassilly: New Juvenile Justice Commission Will Look at Growing Epidemic of Violent Juvenile Crime</a>
											<span class="post-date">November 6, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/11/01/deputies-investigating-fatal-shooting-in-edgewood/">Deputies Investigating Fatal Shooting in Edgewood</a>
											<span class="post-date">November 1, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/10/31/rep-harris-soviet-style-impeachment-hearings-are-a-sham/">Rep. Harris: “Soviet-Style” Impeachment Hearings are a Sham</a>
											<span class="post-date">October 31, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/10/29/exelon-to-pay-200-million-toward-chesapeake-bay-in-conowingo-dam-settlement/">Exelon to Pay $200+ Million Toward Chesapeake Bay in Conowingo Dam Settlement</a>
											<span class="post-date">October 29, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/10/28/dnr-issues-spotted-lanternfly-quarantine-in-cecil-and-harford-counties/">DNR Issues Spotted Lanternfly Quarantine in Cecil and Harford Counties</a>
											<span class="post-date">October 28, 2019</span>
									</li>
					</ul>
		</div></section>
</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2019/12/'> December 2019 &nbsp;(8)</option>
	<option value='http://www.daggerpress.com/2019/11/'> November 2019 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/10/'> October 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/09/'> September 2019 &nbsp;(11)</option>
	<option value='http://www.daggerpress.com/2019/08/'> August 2019 &nbsp;(6)</option>
	<option value='http://www.daggerpress.com/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2019/06/'> June 2019 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2019/05/'> May 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/04/'> April 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/03/'> March 2019 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2019/02/'> February 2019 &nbsp;(21)</option>
	<option value='http://www.daggerpress.com/2019/01/'> January 2019 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/12/'> December 2018 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2018/11/'> November 2018 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2018/10/'> October 2018 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2018/09/'> September 2018 &nbsp;(31)</option>
	<option value='http://www.daggerpress.com/2018/08/'> August 2018 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2018/07/'> July 2018 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/06/'> June 2018 &nbsp;(36)</option>
	<option value='http://www.daggerpress.com/2018/05/'> May 2018 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2018/04/'> April 2018 &nbsp;(50)</option>
	<option value='http://www.daggerpress.com/2018/03/'> March 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/02/'> February 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/01/'> January 2018 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2017/12/'> December 2017 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2017/11/'> November 2017 &nbsp;(45)</option>
	<option value='http://www.daggerpress.com/2017/10/'> October 2017 &nbsp;(57)</option>
	<option value='http://www.daggerpress.com/2017/09/'> September 2017 &nbsp;(42)</option>
	<option value='http://www.daggerpress.com/2017/08/'> August 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/07/'> July 2017 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2017/06/'> June 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/05/'> May 2017 &nbsp;(84)</option>
	<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>
		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/daggerpress" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/daggerpress"><a href="https://www.facebook.com/daggerpress"></a></blockquote></div>
		</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2019 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer>	<div style="display:none">
	<div class="grofile-hash-map-9943ada0a4ac662b8adc37ee7819c8c9">
	</div>
	<div class="grofile-hash-map-218bd57e8b01b90414e9cdbcaf517c03">
	</div>
	<div class="grofile-hash-map-58bc805d6b5ad33c6b2444e3acb48db7">
	</div>
	<div class="grofile-hash-map-f700b2842c6249a63d08ee3f41da0fec">
	</div>
	<div class="grofile-hash-map-99378beb4be7774fe038874a607e197d">
	</div>
	</div>
<style type="text/css" media="screen"></style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2019\/12\/19\/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat\/":112431};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.daggerpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201952'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_ulike_params = {"ajax_url":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","notifications":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=3.5.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=5.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=5.1.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.8.1'></script>
<script async="async" type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201952#ver=201952' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201952.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'2163858',post:'112431',tz:'-5',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '112431' ]);
</script>
</body></html>
