<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<title>Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</title><meta name="robots" content="noodp,noydir" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting Comments Feed" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.9"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=4.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=1.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.5.4' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ulike_obj = {"ajaxurl":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","button_text_u":"Unlike","button_text":"Like","button_type":"image"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-scripts.min.js?ver=1.2.2'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F04%2F23%2Fharford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F04%2F23%2Fharford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="Shortcut Icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" type="image/x-icon" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover { background-color: #999999 !important; border-radius: 6px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 19px; padding: 10px; }  .simple-social-icons ul li a:hover { background-color: #666666 !important; border-color: #ffffff !important; color: #ffffff !important; }</style><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting" />
<meta property="og:url" content="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/" />
<meta property="og:description" content="From the Harford Democratic Club: The newly-constituted HARFORD DEMOCRATIC CLUB will meet on Wednesday April 26 at 7 p.m. at the Harford County Sheriff&#039;s Office Southern Precinct on Pulaski Highway..." />
<meta property="article:published_time" content="2017-04-24T00:10:49+00:00" />
<meta property="article:modified_time" content="2017-04-24T00:28:42+00:00" />
<meta property="article:author" content="http://www.daggerpress.com/author/daggernews/" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />

<!-- BEGIN GADWP v4.9.2 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->


<style id="custom-css-css">@import "http://fonts.googleapis.com/css?family=Droid+Sans";.entry-title{font-size:3.2rem;font-weight:800}.after-entry .widget-title,.archive-title,.comments-title,.widget .entry-title{font-size:1.5rem}.title-area{float:left;padding:0;width:302px}.header-image .site-title a{background-color:none;max-width:302px;min-height:80px;padding:0}.site-header .widget-area{float:right;width:728px}.breadcrumb{font-size:1.2rem}@media only screen and (max-width: 728px){.title-area{width:100%}.site-header .widget-area{width:100%}}body{font-family:'Droid Sans', sans-serif}blockquote,blockquote::before{color:#555}</style>
</head>
<body class="single single-post postid-109276 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope="itemscope" itemtype="http://schema.org/WebPage"><nav class="nav-secondary" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/">About The Dagger</a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/">Advertise</a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/">Contact Us</a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/">Terms of Service</a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div><header class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><aside class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section></aside></div></header><nav class="nav-primary" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/">Local</a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/">Politics</a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/">Schools</a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/">Sirens</a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/category/question-2/">Big Q</a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/">Health/Food</a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/">A&#038;E</a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/">Sports</a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar">Events</a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" role="main" itemprop="mainContentOfPage" itemscope="itemscope" itemtype="http://schema.org/Blog"><div class="breadcrumb">You are here: <a href="http://www.daggerpress.com/">Home</a> / <a href="http://www.daggerpress.com/category/the-dirt/">Politics</a> / Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</div><article class="post-109276 post type-post status-publish format-standard category-the-dirt tag-delegation tag-edgewood tag-harford-democratic-club tag-james entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-04-23T20:10:49+00:00">April 23, 2017</time> By <span class="entry-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a href="http://www.daggerpress.com/author/daggernews/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Dagger News Service</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#comments">2 Comments</a></span> </p></header><div class="entry-content" itemprop="text"><p>From the Harford Democratic Club:</p>
<p>The newly-constituted HARFORD DEMOCRATIC CLUB will meet on Wednesday April 26 at 7 p.m. at the Harford County Sheriff&#8217;s Office Southern Precinct on Pulaski Highway in Edgewood.   The club will be listening to speakers and conducting business.  </p>
<p>At last month&#8217;s meeting members elected officers for 2017-18.  John Campbell was elected president, Chris Boardman was elected secretary and Annie Harvey treasurer.   The position of vice president and board positions still need to be filled. The club will be considering final adoption of the organization&#8217;s bylaws after considering various provisions during the last meeting.</p>
<p>The public is invited to attend.  Membership in the club is $10 per year for regular members and supporting members who are not required to do precinct work may join for $50.   You need not reside in Harford County to join.</p>
<p>Information: 410-679-6704.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/" data-layout="button_count"></div></li><li class="share-twitter"><div class="twitter_button"><iframe allowtransparency="true" frameborder="0" scrolling="no" src="http://platform.twitter.com/widgets/tweet_button.html?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F04%2F23%2Fharford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting%2F&#038;counturl=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F04%2F23%2Fharford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting%2F&#038;count=horizontal&#038;text=Harford%20Democratic%20Club%20Elects%20Leadership%3B%20Former%20Del.%20James%20to%20Speak%20at%20Next%20Meeting%3A" style="width:101px; height:20px;"></iframe></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2017%2F04%2F23%2Fharford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting%2F&#038;description=Harford%20Democratic%20Club%20Elects%20Leadership%3B%20Former%20Del.%20James%20to%20Speak%20at%20Next%20Meeting" data-pin-do="buttonBookmark" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-109276-58fe2e7a93c8e' data-src='//widgets.wp.com/likes/#blog_id=2163858&amp;post_id=109276&amp;origin=www.daggerpress.com&amp;obj_id=2163858-109276-58fe2e7a93c8e' data-name='like-post-frame-2163858-109276-58fe2e7a93c8e'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height:55px'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"><p class="entry-meta"></p></footer></article><section class="author-box" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><img alt='' src='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=140&amp;d=mm&amp;r=g 2x' class='avatar avatar-70 gravatar' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Dagger News Service</span></h4><div class="author-box-content" itemprop="description"><p>Send Us Your News<br />
<a href="mailto:tellus@daggerpress.com">tellus@daggerpress.com</a></p>
</div></section><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-389743">
	<article itemprop="comment" itemscope="itemscope" itemtype="http://schema.org/UserComments">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="creator" itemscope="itemscope" itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/a5e5eae83cc16f9223c0b3b2fa3a7fc0?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a5e5eae83cc16f9223c0b3b2fa3a7fc0?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 gravatar' height='48' width='48' /><span itemprop="name">Jaguar Judy</span> <span class="says">says</span>		 	</p>

			<p class="comment-meta">
				<time class="comment-time" datetime="2017-04-24T11:58:58+00:00" itemprop="commentTime"><a href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#comment-389743" class="comment-time-link" itemprop="url">April 24, 2017 at 11:58 am</a></time>			</p>
		</header>

		<div class="comment-content" itemprop="commentText">
			
			<p>You don&#8217;t need to reside in Harford County to be a member of the Harford Democratic Club? Wow! Times are really tough fr these guys. Newly reconstituted? I guess they are still reeling from the last election results. Still don&#8217;t have enough officers and board members? I am not a registered Democrat in this great state but I could be available to give them some advice for a small consultation fee.  </p>
<p>And this is the first post since the article was published 31 days ago. Looks like the Harford Democratic Club is fading fast. Maybe you better plan a rally or something. Just make sure Boardman isn&#8217;t involved because the last one was a non-event. Andy Harris is laughing so hard . . . . .
<div id="wp-ulike-comment-389743" class="wpulike wpulike-default">
<div class="counter"><a data-ulike-id="389743" data-ulike-type="likeThisComment" data-ulike-status="3" class="wp_ulike_btn image"></a><span class="count-box">1+</span></div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/?replytocom=389743#respond' onclick='return addComment.moveForm( "comment-389743", "389743", "respond", "109276" )' aria-label='Reply to Jaguar Judy'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-389747">
	<article itemprop="comment" itemscope="itemscope" itemtype="http://schema.org/UserComments">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="creator" itemscope="itemscope" itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/42dca4bb51bb4079e59879a037109f3c?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/42dca4bb51bb4079e59879a037109f3c?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 gravatar' height='48' width='48' /><span itemprop="name">Mr. Jackson</span> <span class="says">says</span>		 	</p>

			<p class="comment-meta">
				<time class="comment-time" datetime="2017-04-24T12:50:43+00:00" itemprop="commentTime"><a href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#comment-389747" class="comment-time-link" itemprop="url">April 24, 2017 at 12:50 pm</a></time>			</p>
		</header>

		<div class="comment-content" itemprop="commentText">
			
			<p>Krist/Chris and Dion want to get to the public trough so bad. Good luck to the both of them.
<div id="wp-ulike-comment-389747" class="wpulike wpulike-default">
<div class="counter"><a data-ulike-id="389747" data-ulike-type="likeThisComment" data-ulike-status="3" class="wp_ulike_btn image"></a><span class="count-box">0</span></div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/?replytocom=389747#respond' onclick='return addComment.moveForm( "comment-389747", "389747", "respond", "109276" )' aria-label='Reply to Mr. Jackson'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->
</ol></div>				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.daggerpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8"  aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" /></p>

<div class="captchaSizeDivLarge"><img id="si_image_com" class="si-captcha" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_form_id=com&amp;prefix=qcRJAor9CJ03bl3k" width="175" height="60" alt="CAPTCHA Image" title="CAPTCHA Image" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="qcRJAor9CJ03bl3k" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh Image" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_form_id=com&amp;prefix='); return false;">
      <img class="captchaImgRefresh" src="http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh Image" onclick="this.blur();" /></a>
  </div>
  </div>
<br />
<p><label id="captcha_code_label" for="captcha_code" >CAPTCHA Code</label><span class="required">*</span>
<br /><input id="captcha_code" name="captcha_code" type="text" size="6"  />
</p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='109276' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="eb81b47538" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="192"/></p>				</form>
					</div><!-- #respond -->
		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="search-form" action="http://www.daggerpress.com/" role="search"><input type="search" name="s" placeholder="Search this website&#x2026;" /><input type="submit" value="Search" /></form></div></section><section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Krist/Chris and Dion want to get to the public trough so bad. Good luck to the both of them.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#comment-389747" title="Mr. Jackson | Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting"><strong>Mr. Jackson</strong> | Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You don't need to reside in Harford County to be a member of the Harford Democratic Club? Wow! Times are&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/#comment-389743" title="Jaguar Judy | Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting"><strong>Jaguar Judy</strong> | Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Also did some more research, last year was a step plus a COLA of 1.5% making it roughly 4.5% of&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389737" title="Like a Wolf | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Like a Wolf</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Time to fix HCPS"     You mention there is no job for cyber security educator, then you&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389736" title="That guy | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>That guy</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;So are you saying teachers this year will most likely receive a 1-2% COLA plus that additional 5 million spread&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389665" title="Like a Wolf | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Like a Wolf</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Dogs&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/23/trespassing-joppa-woman-pulled-to-safety-through-window-of-former-home-after-finding-fire/#comment-389660" title="Mr Jackson | Trespassing Joppa Woman Pulled to Safety Through Window of Former Home after Finding Fire"><strong>Mr Jackson</strong> | Trespassing Joppa Woman Pulled to Safety Through Window of Former Home after Finding Fire</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;This story sounds strange to me. If the belongings are outside, and the house is empty, what are 3 dogs&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/23/trespassing-joppa-woman-pulled-to-safety-through-window-of-former-home-after-finding-fire/#comment-389659" title="Mr Jackson | Trespassing Joppa Woman Pulled to Safety Through Window of Former Home after Finding Fire"><strong>Mr Jackson</strong> | Trespassing Joppa Woman Pulled to Safety Through Window of Former Home after Finding Fire</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Boy who cried wolf    Teachers are not the ones getting the 4% in this article.  Read&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389634" title="just sayin again | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>just sayin again</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;This Executive can't fix what's happened to teacher/support staff salary over the past decade but 4% is a nice increase&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389631" title="Like a Wolf | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Like a Wolf</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I always wondered when this happens to an event what happens to ll the food the vendors had prepared for&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/22/romancing-the-chrome-postponed-to-april-29-forecasted-rain-bumps-car-show-a-week/#comment-389597" title="? | &#8220;Romancing the Chrome&#8221; Postponed to April 29; Forecasted Rain Bumps Car Show a Week"><strong>?</strong> | &#8220;Romancing the Chrome&#8221; Postponed to April 29; Forecasted Rain Bumps Car Show a Week</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;7 years. I guess reading isn't your strong suit.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389582" title="just sayin | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>just sayin</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It's about time HCPS started looking for the most cost-effective solution rather than the easiest one.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/20/harford-county-government-public-schools-agree-on-shared-access-to-county-owned-fuel-sites-to-improve-efficiencies-save-costs/#comment-389581" title="Forever Amber | Harford County Government, Public Schools Agree on Shared Access to County-Owned Fuel Sites to Improve Efficiencies, Save Costs"><strong>Forever Amber</strong> | Harford County Government, Public Schools Agree on Shared Access to County-Owned Fuel Sites to Improve Efficiencies, Save Costs</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The simple fact is you lied about there not being a cyber security teacher job opening. Whether or not it&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389579" title="Potato Peeler | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Potato Peeler</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;What name did the "Potato Peeler" call you? What hostility did you receive? It looks to me like you were&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389578" title="SoulCrusher | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>SoulCrusher</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;What a strange comment. Why would you laugh at me wanting to touch base with my friend? Simple fact, Joe&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389568" title="Time to fix HCPS | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Time to fix HCPS</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Keep replying. I look forward to seeing the next one.     How is it so poorly designed&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389566" title="Potato Peeler | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Potato Peeler</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Great review. You have a great sense of humor!&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/21/dagger-movie-night-unforgettable-a-overly-campy-dramatization-of-exs/#comment-389564" title="Laughing | Dagger Movie Night: “Unforgettable” &#8212; An Overly Campy Dramatization of Exes"><strong>Laughing</strong> | Dagger Movie Night: “Unforgettable” &#8212; An Overly Campy Dramatization of Exes</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It has nothing to do with being inept, it's just typical of HCPS's poorly designed site. Why would I click&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389563" title="Time to fix HCPS | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Time to fix HCPS</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Oh, there is nothing different.     You are just too inept to click the "Online Employment Application"&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389562" title="Potato Peeler | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Potato Peeler</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I just went to hcps.org and clicked on certificated job openings.  The only one listed is for a masonry&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389561" title="Time to fix HCPS | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Time to fix HCPS</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Damn that's one cold way to find out you're getting fired&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389558" title="Sarah | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Sarah</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;So, there's a need for more than 1 cyber security teacher?    https://harford.tedk12.com/hire/ViewJob.aspx?JobID=2540&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389557" title="Potato Peeler | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Potato Peeler</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Not sure why people keep harping on the cyber security teacher at Tech.  My friend has been in that&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389555" title="Time to fix HCPS | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>Time to fix HCPS</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;No, but anyone deliberately setting a fire in a home shared by 8 people is a real problem. Try to&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/20/edgewood-man-charged-with-arson-after-allegedly-igniting-townhouse-fire-in-suicide-attempt/#comment-389544" title="Keesha Jackson | Edgewood Man Charged with Arson after Allegedly Igniting Townhouse Fire in Suicide Attempt"><strong>Keesha Jackson</strong> | Edgewood Man Charged with Arson after Allegedly Igniting Townhouse Fire in Suicide Attempt</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The school system in HARCO is a joke... unfair treatment and harrassment of ADULT employees,  try to hide all&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/#comment-389543" title="KL | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries"><strong>KL</strong> | Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section><section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
					<li>
				<a href="http://www.daggerpress.com/2017/04/23/trespassing-joppa-woman-pulled-to-safety-through-window-of-former-home-after-finding-fire/">Trespassing Joppa Woman Pulled to Safety Through Window of Former Home after Finding Fire</a>
							<span class="post-date">April 23, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/">Harford Democratic Club Elects Leadership; Former Del. James to Speak at Next Meeting</a>
							<span class="post-date">April 23, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/23/two-harford-community-college-student-athletes-receive-bruce-hart-memorial-scholarships/">Two Harford Community College Student-Athletes Receive Bruce Hart Memorial Scholarships</a>
							<span class="post-date">April 23, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/23/tour-harford-countys-only-public-housing-complex-at-havre-de-grace-housing-authority-open-house/">Tour Harford County’s Only Public Housing Complex at Havre de Grace Housing Authority Open House</a>
							<span class="post-date">April 23, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/22/romancing-the-chrome-postponed-to-april-29-forecasted-rain-bumps-car-show-a-week/">&#8220;Romancing the Chrome&#8221; Postponed to April 29; Forecasted Rain Bumps Car Show a Week</a>
							<span class="post-date">April 22, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/21/dagger-movie-night-unforgettable-a-overly-campy-dramatization-of-exs/">Dagger Movie Night: “Unforgettable” &#8212; An Overly Campy Dramatization of Exes</a>
							<span class="post-date">April 21, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/20/harford-county-government-public-schools-agree-on-shared-access-to-county-owned-fuel-sites-to-improve-efficiencies-save-costs/">Harford County Government, Public Schools Agree on Shared Access to County-Owned Fuel Sites to Improve Efficiencies, Save Costs</a>
							<span class="post-date">April 20, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/20/romancing-the-chrome-harford-county-public-library-foundation-jarrettsville-lions-club-host-6th-annual-car-show/">Romancing the Chrome: Harford County Public Library Foundation, Jarrettsville Lions Club Host 6th Annual Car Show</a>
							<span class="post-date">April 20, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/20/medstar-health-bel-air-medical-campus-celebrates-1st-year-anniversary/">MedStar Health Bel Air Medical Campus Celebrates 1st Year Anniversary</a>
							<span class="post-date">April 20, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/20/harford-glen-environmental-center-celebrates-new-bird-hide/">Harford Glen Environmental Center Celebrates New Bird Hide</a>
							<span class="post-date">April 20, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/20/edgewood-man-charged-with-arson-after-allegedly-igniting-townhouse-fire-in-suicide-attempt/">Edgewood Man Charged with Arson after Allegedly Igniting Townhouse Fire in Suicide Attempt</a>
							<span class="post-date">April 20, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/19/sen-jennings-every-bill-has-the-potential-to-affect-the-lives-of-all-marylanders/">Sen. Jennings: &#8220;Every Bill Has the Potential to Affect the Lives of All Marylanders&#8221;</a>
							<span class="post-date">April 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/19/fop-municipal-lodge-128-endorses-dougherty-for-havre-de-grace-mayor/">FOP Municipal Lodge #128 Endorses Dougherty for Havre de Grace Mayor</a>
							<span class="post-date">April 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/19/havre-de-grace-water-plant-to-open-for-public-tours/">Havre de Grace Water Plant to Open for Public Tours</a>
							<span class="post-date">April 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/19/aberdeen-farmers-market-in-festival-park-kicks-off-in-may/">Aberdeen Farmer&#8217;s Market in Festival Park Kicks Off in May</a>
							<span class="post-date">April 19, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/17/harford-county-executive-glassman-recommends-fiscally-responsible-fy-18-budget-no-tax-increases-record-investments-in-public-safety-education-libraries/">Harford County Executive Glassman Recommends Fiscally Responsible FY18 Budget; No Tax Increases, Record Investments in Public Safety, Education, Libraries</a>
							<span class="post-date">April 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/17/arson-under-investigation-after-fire-intentionally-set-at-edgewood-apartment/">Arson Under Investigation after Fire Intentionally Set at Edgewood Apartment</a>
							<span class="post-date">April 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/17/harford-county-health-department-recognizes-std-awareness-month-urges-testing/">Harford County Health Department Recognizes STD Awareness Month, Urges Testing</a>
							<span class="post-date">April 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/17/man-shot-twice-in-aberdeen-investigation-continues/">Man Shot Twice in Aberdeen; Investigation Continues</a>
							<span class="post-date">April 17, 2017</span>
						</li>
					<li>
				<a href="http://www.daggerpress.com/2017/04/16/17-yr-old-girl-escapes-fire-in-2nd-story-jump-from-edgewood-townhouse/">17-Yr-Old Girl Escapes Fire in 2nd Story Jump from Edgewood Townhouse</a>
							<span class="post-date">April 16, 2017</span>
						</li>
				</ul>
		</div></section>		</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="footer-widgets-1 widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>
		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="footer-widgets-2 widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="footer-widgets-3 widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap"><iframe src="https://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fdaggerpress&#038;width=300&#038;height=300&#038;colorscheme=light&#038;show_faces=true&#038;stream=false&#038;show_border=true&#038;header=false&#038;force_wall=false" scrolling="no" frameborder="0" style="border: none; overflow: hidden; width: 300px;  height: 300px; background: #fff"></iframe></div></section>
</div></div></div><footer class="site-footer" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer><script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type="text/javascript">
//<![CDATA[
var si_captcha_styles = "\
<!-- begin SI CAPTCHA Anti-Spam - comment form style -->\
<style type='text/css'>\
div#captchaImgDiv { display:block; }\
.captchaSizeDivSmall { width:175px; height:45px; padding-top:10px; }\
.captchaSizeDivLarge { width:250px; height:60px; padding-top:10px; }\
img#si_image_com,#si_image_reg,#si_image_log,#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }\
.captchaImgRefresh { border-style:none; margin:0; vertical-align:bottom; }\
div#captchaInputDiv { display:block; padding-top:15px; padding-bottom:5px; }\
label#captcha_code_label { margin:0; }\
input#captcha_code { width:65px; }\
</style>\
<!-- end SI CAPTCHA Anti-Spam - comment form style -->\
";
jQuery(document).ready(function($) {
$('head').append(si_captcha_styles);
});
//]]>
</script>
	<div style="display:none">
	<div class="grofile-hash-map-9943ada0a4ac662b8adc37ee7819c8c9">
	</div>
	<div class="grofile-hash-map-a5e5eae83cc16f9223c0b3b2fa3a7fc0">
	</div>
	<div class="grofile-hash-map-42dca4bb51bb4079e59879a037109f3c">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2017\/04\/23\/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting\/":109276};
		window.WPCOM_jetpack = true;
				window.WPCOM_site_ID = 2163858;
			</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
		<div id="fb-root"></div><script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
		<script type="text/javascript">
			jQuery( document ).ready( function() {
			    jQuery.getScript( '//platform.linkedin.com/in.js?async=true', function success() {
			        IN.init();
			    });
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);
				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/04/23/harford-democratic-club-elects-leadership-former-del-james-to-speak-at-next-meeting/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=3.1.8'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike-plugins.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.daggerpress.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.2.1'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201717'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=4.4.9'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=4.4.9'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=3.5.4'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=3.5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=3.5.4'></script>
		<iframe src='http://widgets.wp.com/likes/master.html?ver=20141028#ver=20141028&amp;mp6=1' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script type='text/javascript' src='http://stats.wp.com/e-201717.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.5.4',blog:'2163858',post:'109276',tz:'-4',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '109276' ]);
</script>
</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Page Caching using disk: enhanced

 Served from: daggerpress.com @ 2017-04-24 12:57:30 by W3 Total Cache -->