<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry Comments Feed" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.daggerpress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=3.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.0' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F02%2F01%2Finvestigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F02%2F01%2Finvestigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry" />
<meta property="og:url" content="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" />
<meta property="og:description" content="An investigation into allegations of domestic violence and child abuse against Bel Air Police Department Chief Charles Moore has been referred to the Baltimore County Police Department due to poten…" />
<meta property="article:published_time" content="2020-02-01T14:36:18+00:00" />
<meta property="article:modified_time" content="2020-02-01T14:36:18+00:00" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="http://www.daggerpress.com/wp-content/uploads/belair1874polmd_1.jpg" />
<meta property="og:image:width" content="377" />
<meta property="og:image:height" content="450" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry" />
<meta name="twitter:image" content="http://www.daggerpress.com/wp-content/uploads/belair1874polmd_1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<!-- BEGIN GADWP v5.1.1.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<style type="text/css" id="wp-custom-css">
				@import  "http://fonts.googleapis.com/css?family=Droid+Sans";

/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/* Import Fonts
------------------------------------------------------------ */
.entry-title {
	font-size: 3.2rem;
	font-weight: 800;
}

.after-entry .widget-title, .archive-title, .comments-title, .widget .entry-title {
	font-size: 1.5rem;
}

.title-area {
	float: left;
	padding: 0;
	width: 302px;
}

.header-image .site-title a {
	background-color: none;
	max-width: 302px;
	min-height: 80px;
	padding: 0;
}

.site-header .widget-area {
	float: right;
	width: 728px;
}

.breadcrumb {
	font-size: 1.2rem;
}

@media only screen and (max-width: 728px) {
	.title-area {
		width: 100%;
	}
	
	.site-header .widget-area {
		width: 100%;
	}
}

body {
	font-family: 'Droid Sans', sans-serif;
}

blockquote, blockquote::before {
	color: #555;
}			</style>
		</head>
<body class="post-template-default single single-post postid-112465 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url"><span itemprop="name">About The Dagger</span></a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url"><span itemprop="name">Terms of Service</span></a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><div class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/" itemprop="url"><span itemprop="name">Sirens</span></a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/category/question-2/" itemprop="url"><span itemprop="name">Big Q</span></a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/" itemprop="url"><span itemprop="name">Health/Food</span></a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/" itemprop="url"><span itemprop="name">A&#038;E</span></a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar" itemprop="url"><span itemprop="name">Events</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/category/featured/" itemprop="item"><span itemprop="name">Featured</span></a></span> <span aria-label="breadcrumb separator">/</span> Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</div><article class="post-112465 post type-post status-publish format-standard has-post-thumbnail category-featured category-sirens tag-bel-air tag-bel-air-police-department tag-charles-moore tag-harford-county-sheriffs-office tag-jesse-bane tag-police tag-union entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-02-01T09:36:18-05:00">February 1, 2020</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.daggerpress.com/author/aaron/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Aaron Cahall</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comments">25 Comments</a></span> </p></header><div class="entry-content" itemprop="text"><p>An investigation into allegations of domestic violence and child abuse against Bel Air Police Department Chief Charles Moore has been referred to the Baltimore County Police Department due to potential conflicts of interest, while Bel Air’s police union rejected town officials’ comments about the matter and called for an independent investigation.</p>
<p>The town announced Wednesday it had <a href="https://www.belairmd.org/CivicAlerts.aspx?AID=409" rel="noopener noreferrer" target="_blank">placed Moore on administrative leave</a> after he was served with a temporary protective order a day earlier placed by his wife, from whom he is separated, alleging that Moore was involved in a physical altercation with her and their teenage son on Dec. 13.</p>
<p>Harford County Sheriff’s Office spokeswoman Cristie Hopkins said Friday that the agency, which has jurisdiction over the locations where the alleged incidents involving Moore took place, had referred the investigation to the Baltimore County Police Department and Baltimore County State’s Attorney’s Office.</p>
<p>While allegations involving child abuse would usually be investigated by the Harford County Child Advocacy Center, in his role as Bel Air police chief, Moore sits on the center’s Board of Directors.</p>
<p>“This creates an obvious conflict of interest,” she wrote in an e-mail to The Dagger. “As such, we have consulted with and requested assistance from the Baltimore County Police Department and Baltimore County State’s Attorney’s Office to complete the necessary investigations.  We have not been requested to assist with any Internal Investigation the Bel Air Police Department may be conducting.” </p>
<p>Hopkins said standard practices in such an investigation would be to gather evidence, interview involved parties, and to present any findings to the State’s Attorney’s Office for possible charges. A concurrent social services investigation may also be possible, she added.</p>
<p>In <a href="https://www.baltimoresun.com/maryland/harford/aegis/cng-ag-bel-air-police-order-20200130-nb3s5zbjcbbm5o2hwcng5h4sdu-story.html" rel="noopener noreferrer" target="_blank">comments to The Aegis published Friday</a>, Bel Air Town Administrator Jesse Bane said the town would not conduct its own investigation of Moore due to the allegations against him occurring outside its department’s jurisdiction. </p>
<p>“This is nothing unusual,” Bane told the newspaper, &#8220;because the order has been issued does not mean the allegations are true.”</p>
<p>However, Bane’s comments were strongly countered in <a href="https://www.facebook.com/BAPA229/photos/a.1762515320721369/2234829660156597/?type=3&#038;theater" rel="noopener noreferrer" target="_blank">a letter published in the early morning hours Saturday</a> by the Bel Air Police Association IUPA Local #229, the union representing the department’s rank and file officers.</p>
<p>“A police officer being accused of domestic violence and being the respondent of a protective order is highly unusual,” the union wrote. “There is nothing normal about this.”</p>
<p>The union also rejected Bane’s basis for not conducting an investigation due to jurisdictional boundaries.</p>
<p>“This is not a standard that has been applied to officers in the past,” the union wrote. “Whenever a police office is accused of wrongdoing they are subject to an investigation regardless of where the incident occurred. Allegations of misconduct should be investigated thoroughly regardless of jurisdictional boundaries or rank.”</p>
<p>“In the interest of fairness and public trust, an independent investigation into the allegations against Chief Moore must be conducted.”</p>
<p>As Harford Couny Sheriff from 2006 to 2014, Bane previously sat on the the Harford County Child Advocacy Center board; he is a past board member of the county&#8217;s Sexual Assault/Spouse Abuse Resource Center, or SARC.</p>
<p>A hearing for a final protective order is scheduled for Tuesday. Under the temporary protective order, Moore is prohibited from threatening, abusing, contacting, or visiting either his wife or his teenage son. Pursuant to Maryland law, Moore was required to surrender all firearms and ammunition; Hopkins said the Sheriff’s Office claimed a total of 24 firearms from Moore, including his duty weapon.</p>
<p>During Moore&#8217;s absence, Deputy Chief of Police Richard J. Peschek is serving as Acting Chief of Police.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" data-text="Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"  >Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F02%2F01%2Finvestigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry%2F&#038;media=http%3A%2F%2Fwww.daggerpress.com%2Fwp-content%2Fuploads%2Fbelair1874polmd_1.jpg&#038;description=Investigation%20into%20Bel%20Air%20Police%20Chief%20Moore%20Referred%20to%20Baltimore%20Co.%20Police%3B%20Bel%20Air%20Officers%E2%80%99%20Union%20Calls%20for%20Inquiry" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-112465-5e366d189e985' data-src='https://widgets.wp.com/likes/#blog_id=2163858&amp;post_id=112465&amp;origin=www.daggerpress.com&amp;obj_id=2163858-112465-5e366d189e985' data-name='like-post-frame-2163858-112465-5e366d189e985'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='http://0.gravatar.com/avatar/64809046a9954eaf07a4860f5513b2c1?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/64809046a9954eaf07a4860f5513b2c1?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Aaron Cahall</span></h4><div class="author-box-content" itemprop="description"><p>Associate Editor<br />
<a href="mailto:aaron@daggerpress.com">aaron@daggerpress.com</a></p>
</div></section><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-455796">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/a85d1e0fe4fc1fcc819713c14002544a?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a85d1e0fe4fc1fcc819713c14002544a?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Cecil’s Whig</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T09:41:46-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455796" class="comment-time-link" itemprop="url">February 1, 2020 at 9:41 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>24 firearms? Yikes!		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455796"
					data-ulike-nonce="8effbebcd4"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">2+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455796#respond' data-commentid="455796" data-postid="112465" data-belowelement="comment-455796" data-respondelement="respond" aria-label='Reply to Cecil’s Whig'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-455798">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/31d58acf735322940d4153bd9b3a9768?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/31d58acf735322940d4153bd9b3a9768?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">5.0</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T09:47:26-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455798" class="comment-time-link" itemprop="url">February 1, 2020 at 9:47 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Looks like the police department doesn&#8217;t trust Bane any moore than the sheriffs department did.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455798"
					data-ulike-nonce="cada045f06"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">7+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455798#respond' data-commentid="455798" data-postid="112465" data-belowelement="comment-455798" data-respondelement="respond" aria-label='Reply to 5.0'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-455799">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Belairlover2</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T10:23:36-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455799" class="comment-time-link" itemprop="url">February 1, 2020 at 10:23 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Wow for a man who was Sheriff and who was on the SARC board Mr Bane certainly doesn’t seem to take this seriously.  I was also shocked when I read in the Sun that he also seemed to called the victim a liar.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455799"
					data-ulike-nonce="f71cc577a1"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">10+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455799#respond' data-commentid="455799" data-postid="112465" data-belowelement="comment-455799" data-respondelement="respond" aria-label='Reply to Belairlover2'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-2" id="comment-455800">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/f7917cc2e1272fce88f3491a651a4e11?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f7917cc2e1272fce88f3491a651a4e11?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Angry Resident</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T10:31:22-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455800" class="comment-time-link" itemprop="url">February 1, 2020 at 10:31 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>“This is nothing unusual,” Bane told the newspaper, “because the order has been issued does not mean the allegations are true.”</p>
<p>Does anyone think Jesse Bane hasn&#8217;t already made up his mind! No wonder he says an investigation isn&#8217;t needed! Brave of the union to stand up to this type of cover up!		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455800"
					data-ulike-nonce="f2f3e26353"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">8+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455800#respond' data-commentid="455800" data-postid="112465" data-belowelement="comment-455800" data-respondelement="respond" aria-label='Reply to Angry Resident'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even depth-2" id="comment-455801">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/43e9ed7d73f30f6cd63da5cc4872cf0b?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/43e9ed7d73f30f6cd63da5cc4872cf0b?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">MeToo except Jesse</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T10:35:40-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455801" class="comment-time-link" itemprop="url">February 1, 2020 at 10:35 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Questioning the victim&#8217;s honesty while saying no investigation is needed!! Jesse Bane needs to GO!		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455801"
					data-ulike-nonce="d874f82826"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">10+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455801#respond' data-commentid="455801" data-postid="112465" data-belowelement="comment-455801" data-respondelement="respond" aria-label='Reply to MeToo except Jesse'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-455803">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/469a4a9db8abd816b1ff4e1fba1df809?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/469a4a9db8abd816b1ff4e1fba1df809?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Once a Democrat</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T11:03:46-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455803" class="comment-time-link" itemprop="url">February 1, 2020 at 11:03 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Sounds like the Town needs another investigation into the attempted cover up by Bane. Anyone else having flashbacks of Forewood?		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455803"
					data-ulike-nonce="eab3a6d455"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">8+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455803#respond' data-commentid="455803" data-postid="112465" data-belowelement="comment-455803" data-respondelement="respond" aria-label='Reply to Once a Democrat'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment even depth-2" id="comment-455817">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/d0b511cf67019d078a0ab2ba7b0745ab?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/d0b511cf67019d078a0ab2ba7b0745ab?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Sally</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:47:26-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455817" class="comment-time-link" itemprop="url">February 1, 2020 at 2:47 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>So what you are asking for is to have the Bel Air Police investigate their chief for a crime that happened outside of their town. Come on man		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455817"
					data-ulike-nonce="f70609f2d3"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455817#respond' data-commentid="455817" data-postid="112465" data-belowelement="comment-455817" data-respondelement="respond" aria-label='Reply to Sally'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-3" id="comment-455829">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/15518ec7dfc9296bc56e88f3625024df?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/15518ec7dfc9296bc56e88f3625024df?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">IAD101</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T17:34:18-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455829" class="comment-time-link" itemprop="url">February 1, 2020 at 5:34 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Yes just like any police department would do when a member of their agency is accused of domestic violence.  It’s police internal investigations 101.  He should have another agency conduct the investigation because it’s the chief who is accused.  But it’s typical Bane incompetence to not conduct an investigation.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455829"
					data-ulike-nonce="02c9d3f0fe"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455829#respond' data-commentid="455829" data-postid="112465" data-belowelement="comment-455829" data-respondelement="respond" aria-label='Reply to IAD101'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even depth-3" id="comment-455838">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/f9691c273e2092da4100f2a7fc8c4269?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f9691c273e2092da4100f2a7fc8c4269?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Jake</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T21:29:58-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455838" class="comment-time-link" itemprop="url">February 1, 2020 at 9:29 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>There should be an IA investigation into it regardless of where the incident occurred.  If this was a patrol officer they would absolutely be doing an IA investigation whether it happened in Bel Air town, out in Harford County someplace, or in PA.  </p>
<p>Bane a fucking idiot.  He&#8217;s the same guy who kept a major suspended with pay for months even though Forewood had been charged with a felony.  Bane claimed that he couldn&#8217;t do anything more unless he was convicted because of LEOBR, which was bs because Forewood wasn&#8217;t protected by LEOBR and once you&#8217;re charged with a felony you can suspended without pay anyway.  Bane magically decided to fire Forewood just before the election even though he hadn&#8217;t even gone to trial yet, let alone been found guilty of anything.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455838"
					data-ulike-nonce="7996924f10"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455838#respond' data-commentid="455838" data-postid="112465" data-belowelement="comment-455838" data-respondelement="respond" aria-label='Reply to Jake'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-4" id="comment-455839">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/bf951ddfe14e958f0a5dceafeb3cf8b9?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/bf951ddfe14e958f0a5dceafeb3cf8b9?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Lizzie</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T21:38:35-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455839" class="comment-time-link" itemprop="url">February 1, 2020 at 9:38 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Sounds like this was written by HCSO command staff, imagine that. Since you are thinking this is a conspiracy, did Bane not suspend the Chief? Read the article is Baltimore County not investigating? Maybe the results lead to an internal investigation, maybe we find out this whole thing is BS. All TBD but like the union you have already made your mind up. Sad but you know what I’m not shocked.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455839"
					data-ulike-nonce="51f62002a0"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455839#respond' data-commentid="455839" data-postid="112465" data-belowelement="comment-455839" data-respondelement="respond" aria-label='Reply to Lizzie'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-455804">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Belairlover2</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T11:05:35-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455804" class="comment-time-link" itemprop="url">February 1, 2020 at 11:05 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Obviously he has made up his mind and thinks the victim is a liar but I am surprised that he was dumb enough to say it in the news paper.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455804"
					data-ulike-nonce="223ae03649"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">13+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455804#respond' data-commentid="455804" data-postid="112465" data-belowelement="comment-455804" data-respondelement="respond" aria-label='Reply to Belairlover2'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-2" id="comment-455816">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/9af96f8fb88a8b38a04b107f6bf95d82?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9af96f8fb88a8b38a04b107f6bf95d82?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Local Yocal</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:45:35-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455816" class="comment-time-link" itemprop="url">February 1, 2020 at 2:45 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Made up his mind how? Didn’t he suspend the Chief??		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455816"
					data-ulike-nonce="4de05b0ff2"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455816#respond' data-commentid="455816" data-postid="112465" data-belowelement="comment-455816" data-respondelement="respond" aria-label='Reply to Local Yocal'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment even depth-3" id="comment-455818">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/8b807c79d7580df0f47850de717f9980?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/8b807c79d7580df0f47850de717f9980?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Okay Boomer</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:54:45-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455818" class="comment-time-link" itemprop="url">February 1, 2020 at 2:54 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>What he did was completely disrespect the officers of the Bel Air Police Department and call the victim a liar. Defend all you want, sad attempt to cover up.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455818"
					data-ulike-nonce="fe22282a73"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455818#respond' data-commentid="455818" data-postid="112465" data-belowelement="comment-455818" data-respondelement="respond" aria-label='Reply to Okay Boomer'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-4" id="comment-455819">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/273a006a451041f3d236205c3bc85be4?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/273a006a451041f3d236205c3bc85be4?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Local Yocal</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:58:57-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455819" class="comment-time-link" itemprop="url">February 1, 2020 at 2:58 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>How did he disrespect the Officers of the Bel Air Police Department? Please enlighten me		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455819"
					data-ulike-nonce="f319d1b8eb"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455819#respond' data-commentid="455819" data-postid="112465" data-belowelement="comment-455819" data-respondelement="respond" aria-label='Reply to Local Yocal'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment even depth-5" id="comment-455821">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/a23eb465b6d9eac88e956f5aa6789ac1?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a23eb465b6d9eac88e956f5aa6789ac1?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Okay Boomer</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T15:34:24-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455821" class="comment-time-link" itemprop="url">February 1, 2020 at 3:34 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>It is not the norm for the union that represents the town officers to have to come out with a press statement that contradicts several things that town administrator claimed. The union making the release brings even more attention on the unfortunate situation between the chief and his family members. Placing the officers who work for Bane in that difficult situation is very disrespectful to the rank and file officers.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455821"
					data-ulike-nonce="9264445f64"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt depth-5" id="comment-455822">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/38cc7765c60f888bfaa35f95fc23707b?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/38cc7765c60f888bfaa35f95fc23707b?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Local Yocal</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T15:53:01-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455822" class="comment-time-link" itemprop="url">February 1, 2020 at 3:53 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>You still didn’t answer my question. How Did he disrespect the Bel Air Police Department?? His son Punches him in the face and  he defends himself. I’m not a Bane fan but it is correct that several Harford County Deputies have had a protective order placed on them. Again where is the disrespect????		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455822"
					data-ulike-nonce="42860c9dc6"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even depth-5" id="comment-455826">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/dae1960bb26ac8ceb2e3d158e905a896?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Belairlover2</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T17:22:43-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455826" class="comment-time-link" itemprop="url">February 1, 2020 at 5:22 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Bane said it was nothing unusual which is a slap in the face to all the BPD officers.  He also isn’t having an internal investigation conducted which what would happen with any other officer. That’s another slap.  Not to mention he called the victim of this domestic incident a liar.  So he disrespected the officers of the Town twice and the victim.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455826"
					data-ulike-nonce="ae4d3575f0"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment odd alt depth-3" id="comment-455827">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/6e6ee3fe26ea7e7298992e672f36a88c?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/6e6ee3fe26ea7e7298992e672f36a88c?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">See through</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T17:26:54-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455827" class="comment-time-link" itemprop="url">February 1, 2020 at 5:26 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>By calling the victim a liar and not conducting an investigation he has already decided the outcome.  He had no choice but to suspend or he wouldn’t have.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455827"
					data-ulike-nonce="15537d1754"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455827#respond' data-commentid="455827" data-postid="112465" data-belowelement="comment-455827" data-respondelement="respond" aria-label='Reply to See through'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment even thread-odd thread-alt depth-1" id="comment-455805">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/e26a9467cdac2ef5cb941dcb3fbae612?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/e26a9467cdac2ef5cb941dcb3fbae612?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Townie</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T12:24:37-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455805" class="comment-time-link" itemprop="url">February 1, 2020 at 12:24 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Sad event for the family, but a total Bane boondoggle as usual. The Aegis article says none of the five commissioners bothered calling back and the town administrator insults the victim, insults the police officers and embarrasses us all.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455805"
					data-ulike-nonce="4e075e7cdb"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">7+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455805#respond' data-commentid="455805" data-postid="112465" data-belowelement="comment-455805" data-respondelement="respond" aria-label='Reply to Townie'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment odd alt depth-2" id="comment-455815">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/719603a265d198b2b6476eaf644adee5?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/719603a265d198b2b6476eaf644adee5?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Frank</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:44:22-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455815" class="comment-time-link" itemprop="url">February 1, 2020 at 2:44 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Why would the commissioners comment, that’s typical that politicians don’t get involved in police related issues especially when one of their own is being investigated. They suspended him, what more do you want them to do?		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455815"
					data-ulike-nonce="edcfce7564"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455815#respond' data-commentid="455815" data-postid="112465" data-belowelement="comment-455815" data-respondelement="respond" aria-label='Reply to Frank'>Reply</a></div>
		 
	</article>
	<ul class="children">

	<li class="comment even depth-3" id="comment-455836">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/7131f3e5841624f4c0306c061ef0af9e?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7131f3e5841624f4c0306c061ef0af9e?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Townie</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T21:24:33-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455836" class="comment-time-link" itemprop="url">February 1, 2020 at 9:24 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Maybe if they could have been bothered to respond, Bane’s outrageous comments wouldn’t have been made.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455836"
					data-ulike-nonce="865ce9bbd3"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455836#respond' data-commentid="455836" data-postid="112465" data-belowelement="comment-455836" data-respondelement="respond" aria-label='Reply to Townie'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment odd alt thread-even depth-1" id="comment-455813">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/384e0f5ce4cbc773dbd4cd08dd8b9e3d?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/384e0f5ce4cbc773dbd4cd08dd8b9e3d?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Allen J</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T14:38:29-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455813" class="comment-time-link" itemprop="url">February 1, 2020 at 2:38 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Wait so son punches father and father defends himself. I read what was posted and I just don’t see enough for a protective order. Keep it classy Bel Air PD Union, not sure why got involved.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455813"
					data-ulike-nonce="d633002d98"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">1+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455813#respond' data-commentid="455813" data-postid="112465" data-belowelement="comment-455813" data-respondelement="respond" aria-label='Reply to Allen J'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-odd thread-alt depth-1" id="comment-455824">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/e82d64c37a011f9ea037d3a07f68f5ec?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/e82d64c37a011f9ea037d3a07f68f5ec?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Al</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T16:29:28-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455824" class="comment-time-link" itemprop="url">February 1, 2020 at 4:29 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Sounds to me like the Bel Air Police Union is mad because they have a chief that actually makes them work. They have the best law enforcement job in the county, yet they are whining. Rumor is many officers are leaving this pathetic union and joining the FOP with Aberdeen and Havre DeGrace. This press release is joke		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455824"
					data-ulike-nonce="844b859bec"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">3+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455824#respond' data-commentid="455824" data-postid="112465" data-belowelement="comment-455824" data-respondelement="respond" aria-label='Reply to Al'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-even depth-1" id="comment-455841">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/29c7248b896e4734c858812ee953463c?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/29c7248b896e4734c858812ee953463c?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Tellitlikeitis</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T21:49:24-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455841" class="comment-time-link" itemprop="url">February 1, 2020 at 9:49 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Harford County never fails to amaze me.  The corruption and inept prevail again.  The corrupt judges will be involved next.  Maybe retired felon HCSO Officers will help the &#8220;independent investigation.&#8221;  Time to bring Keplin back with his night stick!		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455841"
					data-ulike-nonce="2272e61ed1"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">0</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455841#respond' data-commentid="455841" data-postid="112465" data-belowelement="comment-455841" data-respondelement="respond" aria-label='Reply to Tellitlikeitis'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-odd thread-alt depth-1" id="comment-455843">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/edb4514a640339c0f020eed56e649a0c?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/edb4514a640339c0f020eed56e649a0c?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Loaner</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2020-02-01T22:27:46-05:00" itemprop="datePublished"><a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455843" class="comment-time-link" itemprop="url">February 1, 2020 at 10:27 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>“There is nothing normal about this”,  The Chief has always had our back and I cant believe we have decided to turn our back on him. You and I both know this is BS and I won’t and can’t watch him get thrown under the bus. You may not like what he tells us but I’m stunned that you decided to turn your back.  This guy was just trying to get his son back on track. The same as you would want your own son to do good. Say what you want and do what you will but this isn’t right and I’m not sure what your end game is but this is ridiculous.		</p>
<div class="wpulike wpulike-default ">
<div class="wp_ulike_general_class wp_ulike_is_unliked"><button type="button"
					data-ulike-id="455843"
					data-ulike-nonce="77b91233b6"
					data-ulike-type="likeThisComment"
					data-ulike-status="3" class="wp_ulike_btn wp_ulike_put_image"></button><span class="count-box">2+</span>			</div>
</div>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/?replytocom=455843#respond' data-commentid="455843" data-postid="112465" data-belowelement="comment-455843" data-respondelement="respond" aria-label='Reply to Loaner'>Reply</a></div>
		 
	</article>
	</li><!-- #comment-## -->
</ol></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.daggerpress.com/wp-comments-post.php?wpe-comment-post=sp20183cbm0e7" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='112465' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="096d80e4ed" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="161"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.daggerpress.com/" role="search"><meta itemprop="target" content="http://www.daggerpress.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;“There is nothing normal about this”, The Chief has always had our back and I cant believe we have decided&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455843" title="Loaner | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Loaner</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Harford County never fails to amaze me. The corruption and inept prevail again. The corrupt judges will be involved next.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455841" title="Tellitlikeitis | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Tellitlikeitis</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Sounds like this was written by HCSO command staff, imagine that. Since you are thinking this is a conspiracy, did&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455839" title="Lizzie | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Lizzie</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;There should be an IA investigation into it regardless of where the incident occurred. If this was a patrol officer&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455838" title="Jake | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Jake</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Maybe if they could have been bothered to respond, Bane’s outrageous comments wouldn’t have been made.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455836" title="Townie | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Townie</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Feb. 1 (UPI) -- In a midnight court filing Friday, the Department of Justice reveled the existence of 24 emails&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-455834" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Hillary had her chance in 2016 and she failed to consolidate and energize the Democrats to beat Trump. It's time&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-455833" title="Bob | Suspects Taken into Custody for Havre de Grace Assault"><strong>Bob</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You know as well as I do they offer you the assessment value which is not the fair market value.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/01/23/sen-jennings-addressing-violent-crime-polar-bear-plunge-joppa-park-n-ride-petition/#comment-455832" title="Cdev | Sen. Jennings: Addressing Violent Crime; Polar Bear Plunge; Joppa Park-N-Ride Petition"><strong>Cdev</strong> | Sen. Jennings: Addressing Violent Crime; Polar Bear Plunge; Joppa Park-N-Ride Petition</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"A freshly installed section of President Trump’s “virtually impenetrable” U.S. border wall got blown over by high winds on Wednesday,&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/07/12/suspects-taken-into-custody-for-havre-de-grace-assault/#comment-455831" title="Bob | Suspects Taken into Custody for Havre de Grace Assault"><strong>Bob</strong> | Suspects Taken into Custody for Havre de Grace Assault</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Yes just like any police department would do when a member of their agency is accused of domestic violence. It’s&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455829" title="IAD101 | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>IAD101</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Iamthewhistleblower, your point that, "World leaders are just waiting for this "sh$tshow to end", is well- taken. As Americans, we&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-455828" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;By calling the victim a liar and not conducting an investigation he has already decided the outcome. He had no&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455827" title="See through | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>See through</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Bane said it was nothing unusual which is a slap in the face to all the BPD officers. He also&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455826" title="Belairlover2 | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Belairlover2</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;No. Both of you are out of your minds. Biden went out bragging about how he got a prosecutor fired&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-455825" title="SoulCrusher | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>SoulCrusher</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Sounds to me like the Bel Air Police Union is mad because they have a chief that actually makes them&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455824" title="Al | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Al</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You still didn’t answer my question. How Did he disrespect the Bel Air Police Department?? His son Punches him in&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455822" title="Local Yocal | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Local Yocal</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It is not the norm for the union that represents the town officers to have to come out with a&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455821" title="Okay Boomer | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Okay Boomer</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;How did he disrespect the Officers of the Bel Air Police Department? Please enlighten me&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455819" title="Local Yocal | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Local Yocal</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;What he did was completely disrespect the officers of the Bel Air Police Department and call the victim a liar.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455818" title="Okay Boomer | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Okay Boomer</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;So what you are asking for is to have the Bel Air Police investigate their chief for a crime that&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455817" title="Sally | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Sally</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Made up his mind how? Didn’t he suspend the Chief??&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455816" title="Local Yocal | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Local Yocal</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Why would the commissioners comment, that’s typical that politicians don’t get involved in police related issues especially when one of&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455815" title="Frank | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Frank</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Wait so son punches father and father defends himself. I read what was posted and I just don’t see enough&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455813" title="Allen J | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Allen J</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;SoulCrusher, It's time for you climb up &amp; out of that Trump Rabbit Hole that you find yourself in. You&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/#comment-455810" title="Bob | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;"><strong>Bob</strong> | Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Sad event for the family, but a total Bane boondoggle as usual. The Aegis article says none of the five&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/#comment-455805" title="Townie | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry"><strong>Townie</strong> | Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section>
<section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
											<li>
					<a href="http://www.daggerpress.com/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" aria-current="page">Investigation into Bel Air Police Chief Moore Referred to Baltimore Co. Police; Bel Air Officers’ Union Calls for Inquiry</a>
											<span class="post-date">February 1, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/31/sheriffs-office-to-hold-memorial-blood-drive-honoring-dailey-logsdon/">Sheriff&#8217;s Office to Hold Memorial Blood Drive Honoring Dailey, Logsdon</a>
											<span class="post-date">January 31, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/23/sen-jennings-addressing-violent-crime-polar-bear-plunge-joppa-park-n-ride-petition/">Sen. Jennings: Addressing Violent Crime; Polar Bear Plunge; Joppa Park-N-Ride Petition</a>
											<span class="post-date">January 23, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/22/street-man-arrested-after-ambushing-sheriffs-deputies-shooting-neighbor-killing-dog/">Street Man Arrested After Ambushing Sheriff’s Deputies, Shooting Neighbor, Killing Dog</a>
											<span class="post-date">January 22, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/22/dozens-of-shots-fired-at-police-neighbor-shot-after-deputies-respond-to-domestic-incident-in-street/">Dozens of Shots Fired at Police, Neighbor Hit after Deputies Respond to Domestic Incident in Street</a>
											<span class="post-date">January 22, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/16/havre-de-grace-announces-special-election-for-ballot-questions/">Havre de Grace Announces Special Election for Ballot Questions</a>
											<span class="post-date">January 16, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/15/harford-executive-announces-32-decline-in-opioid-fatalities-unprecedented-partnerships-for-public-safety-coastal-resilience-in-annual-state-of-the-county-address/">Harford Executive Announces 32% Decline in Opioid Fatalities, Unprecedented Partnerships for Public Safety &#038; Coastal Resilience in Annual State of the County Address</a>
											<span class="post-date">January 15, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/09/rep-harris-votes-against-purely-political-resolution-seeking-to-tie-the-presidents-hands-as-he-responds-to-terrorist-threats/">Rep. Harris Votes Against “Purely Political Resolution Seeking to Tie the President’s Hands” as He Responds to Terrorist Threats</a>
											<span class="post-date">January 9, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/05/virginia-woman-arrested-in-connection-to-harford-community-college-bomb-threat/">Virginia Woman Arrested in Connection to Harford Community College Bomb Threat</a>
											<span class="post-date">January 5, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/01/01/havre-de-grace-man-stabbed-in-new-years-eve-assault/">Havre de Grace Man Stabbed in New Year’s Assault</a>
											<span class="post-date">January 1, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/27/edgewood-man-arrested-in-homicide-of-2-yr-old-havre-de-grace-girl/">Edgewood Man Arrested in Homicide of 2-Yr-Old Havre de Grace Girl</a>
											<span class="post-date">December 27, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/27/aberdeen-man-arrested-for-2-armed-robberies/">Aberdeen Man Arrested for 2 Armed Robberies</a>
											<span class="post-date">December 27, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/26/harford-county-public-schools-mourns-loss-of-board-member-kathy-carmello/">Harford County Public Schools Mourns Loss of Board Member Kathy Carmello</a>
											<span class="post-date">December 26, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/23/two-men-apprehended-for-armed-robbery-after-vehicle-pursuit-into-havre-de-grace/">Two Men Apprehended for Armed Robbery after Vehicle Pursuit into Havre de Grace</a>
											<span class="post-date">December 23, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/19/mike-griffith-nominated-to-fill-cassillys-district-35b-delegate-seat/">Mike Griffith Nominated to Fill Cassilly’s District 35B Delegate Seat</a>
											<span class="post-date">December 19, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/19/drunk-driver-arrested-after-crashing-into-aberdeen-police-car/">Drunk Driver Arrested after Crashing into Aberdeen Police Car</a>
											<span class="post-date">December 19, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/18/rep-harris-on-president-trumps-impeachment-the-american-people-arent-fooled-so-easily/">Rep. Harris on President Trump&#8217;s Impeachment: &#8220;The American People Aren&#8217;t Fooled So Easily&#8221;</a>
											<span class="post-date">December 18, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/06/aberdeen-man-arrested-for-possession-of-child-pornography/">Aberdeen Man Arrested for Possession of Child Pornography</a>
											<span class="post-date">December 6, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/04/delaware-thieves-caught-in-the-act-at-harford-mall/">Delaware Thieves Caught in the Act at Harford Mall</a>
											<span class="post-date">December 4, 2019</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2019/12/03/republican-central-committee-of-harford-county-seeks-applications-to-fill-del-cassillys-seat/">Republican Central Committee of Harford County Seeks Applications to Fill Del. Cassilly&#8217;s Seat</a>
											<span class="post-date">December 3, 2019</span>
									</li>
					</ul>
		</div></section>
</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2020/02/'> February 2020 &nbsp;(1)</option>
	<option value='http://www.daggerpress.com/2020/01/'> January 2020 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/12/'> December 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/11/'> November 2019 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/10/'> October 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/09/'> September 2019 &nbsp;(11)</option>
	<option value='http://www.daggerpress.com/2019/08/'> August 2019 &nbsp;(6)</option>
	<option value='http://www.daggerpress.com/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2019/06/'> June 2019 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2019/05/'> May 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/04/'> April 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/03/'> March 2019 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2019/02/'> February 2019 &nbsp;(21)</option>
	<option value='http://www.daggerpress.com/2019/01/'> January 2019 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/12/'> December 2018 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2018/11/'> November 2018 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2018/10/'> October 2018 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2018/09/'> September 2018 &nbsp;(31)</option>
	<option value='http://www.daggerpress.com/2018/08/'> August 2018 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2018/07/'> July 2018 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/06/'> June 2018 &nbsp;(36)</option>
	<option value='http://www.daggerpress.com/2018/05/'> May 2018 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2018/04/'> April 2018 &nbsp;(50)</option>
	<option value='http://www.daggerpress.com/2018/03/'> March 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/02/'> February 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/01/'> January 2018 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2017/12/'> December 2017 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2017/11/'> November 2017 &nbsp;(45)</option>
	<option value='http://www.daggerpress.com/2017/10/'> October 2017 &nbsp;(57)</option>
	<option value='http://www.daggerpress.com/2017/09/'> September 2017 &nbsp;(42)</option>
	<option value='http://www.daggerpress.com/2017/08/'> August 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/07/'> July 2017 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2017/06/'> June 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/05/'> May 2017 &nbsp;(84)</option>
	<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/daggerpress" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/daggerpress"><a href="https://www.facebook.com/daggerpress"></a></blockquote></div>
		</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2020 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer>	<div style="display:none">
	<div class="grofile-hash-map-64809046a9954eaf07a4860f5513b2c1">
	</div>
	<div class="grofile-hash-map-a85d1e0fe4fc1fcc819713c14002544a">
	</div>
	<div class="grofile-hash-map-31d58acf735322940d4153bd9b3a9768">
	</div>
	<div class="grofile-hash-map-dae1960bb26ac8ceb2e3d158e905a896">
	</div>
	<div class="grofile-hash-map-f7917cc2e1272fce88f3491a651a4e11">
	</div>
	<div class="grofile-hash-map-43e9ed7d73f30f6cd63da5cc4872cf0b">
	</div>
	<div class="grofile-hash-map-469a4a9db8abd816b1ff4e1fba1df809">
	</div>
	<div class="grofile-hash-map-d0b511cf67019d078a0ab2ba7b0745ab">
	</div>
	<div class="grofile-hash-map-15518ec7dfc9296bc56e88f3625024df">
	</div>
	<div class="grofile-hash-map-f9691c273e2092da4100f2a7fc8c4269">
	</div>
	<div class="grofile-hash-map-bf951ddfe14e958f0a5dceafeb3cf8b9">
	</div>
	<div class="grofile-hash-map-9af96f8fb88a8b38a04b107f6bf95d82">
	</div>
	<div class="grofile-hash-map-8b807c79d7580df0f47850de717f9980">
	</div>
	<div class="grofile-hash-map-273a006a451041f3d236205c3bc85be4">
	</div>
	<div class="grofile-hash-map-a23eb465b6d9eac88e956f5aa6789ac1">
	</div>
	<div class="grofile-hash-map-38cc7765c60f888bfaa35f95fc23707b">
	</div>
	<div class="grofile-hash-map-6e6ee3fe26ea7e7298992e672f36a88c">
	</div>
	<div class="grofile-hash-map-e26a9467cdac2ef5cb941dcb3fbae612">
	</div>
	<div class="grofile-hash-map-719603a265d198b2b6476eaf644adee5">
	</div>
	<div class="grofile-hash-map-7131f3e5841624f4c0306c061ef0af9e">
	</div>
	<div class="grofile-hash-map-384e0f5ce4cbc773dbd4cd08dd8b9e3d">
	</div>
	<div class="grofile-hash-map-e82d64c37a011f9ea037d3a07f68f5ec">
	</div>
	<div class="grofile-hash-map-29c7248b896e4734c858812ee953463c">
	</div>
	<div class="grofile-hash-map-edb4514a640339c0f020eed56e649a0c">
	</div>
	</div>
<style type="text/css" media="screen"></style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2020\/02\/01\/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry\/":112465};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2020/02/01/investigation-into-bel-air-police-chief-moore-referred-to-baltimore-co-police-bel-air-officers-union-calls-for-inquiry/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.daggerpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202005'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_ulike_params = {"ajax_url":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","notifications":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=3.5.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.8.1'></script>
<script async="async" type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202005#ver=202005' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202005.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'2163858',post:'112465',tz:'-5',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '112465' ]);
</script>
</body></html>
