<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year Comments Feed" href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.daggerpress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=3.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.0' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://www.daggerpress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F04%2F23%2Felizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F04%2F23%2Felizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year" />
<meta property="og:url" content="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" />
<meta property="og:description" content="From Harford County Public Schools: Elizabeth White, Social Studies teacher at Harford Technical High School with 12 years of teaching experience for Harford County Public Schools (HCPS), was named…" />
<meta property="article:published_time" content="2020-04-24T00:03:49+00:00" />
<meta property="article:modified_time" content="2020-04-24T00:03:49+00:00" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="http://www.daggerpress.com/wp-content/uploads/E12DA162-B4BE-43C9-8111-FEA533710F1D.jpeg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="773" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<!-- BEGIN GADWP v5.1.1.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<style type="text/css" id="wp-custom-css">
				@import  "http://fonts.googleapis.com/css?family=Droid+Sans";

/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/* Import Fonts
------------------------------------------------------------ */
.entry-title {
	font-size: 3.2rem;
	font-weight: 800;
}

.after-entry .widget-title, .archive-title, .comments-title, .widget .entry-title {
	font-size: 1.5rem;
}

.title-area {
	float: left;
	padding: 0;
	width: 302px;
}

.header-image .site-title a {
	background-color: none;
	max-width: 302px;
	min-height: 80px;
	padding: 0;
}

.site-header .widget-area {
	float: right;
	width: 728px;
}

.breadcrumb {
	font-size: 1.2rem;
}

@media only screen and (max-width: 728px) {
	.title-area {
		width: 100%;
	}
	
	.site-header .widget-area {
		width: 100%;
	}
}

body {
	font-family: 'Droid Sans', sans-serif;
}

blockquote, blockquote::before {
	color: #555;
}			</style>
		</head>
<body class="post-template-default single single-post postid-112517 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url"><span itemprop="name">About The Dagger</span></a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url"><span itemprop="name">Terms of Service</span></a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><div class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/" itemprop="url"><span itemprop="name">Sirens</span></a></li>
<li id="menu-item-97495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97495"><a href="http://www.daggerpress.com/category/question-2/" itemprop="url"><span itemprop="name">Big Q</span></a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/" itemprop="url"><span itemprop="name">Health/Food</span></a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/" itemprop="url"><span itemprop="name">A&#038;E</span></a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-37925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37925"><a title="Events" href="http://www.harfordsheart.com/calendar" itemprop="url"><span itemprop="name">Events</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/category/the-school-yard/" itemprop="item"><span itemprop="name">Schools</span></a></span> <span aria-label="breadcrumb separator">/</span> Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year</div><article class="post-112517 post type-post status-publish format-standard category-the-school-yard entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-04-23T20:03:49-04:00">April 23, 2020</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.daggerpress.com/author/daggernews/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Dagger News Service</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><img src="http://www.daggerpress.com/wp-content/uploads/E12DA162-B4BE-43C9-8111-FEA533710F1D.jpeg" alt="" width="640" height="773" class="aligncenter size-full wp-image-112518" srcset="http://www.daggerpress.com/wp-content/uploads/E12DA162-B4BE-43C9-8111-FEA533710F1D.jpeg 640w, http://www.daggerpress.com/wp-content/uploads/E12DA162-B4BE-43C9-8111-FEA533710F1D-248x300.jpeg 248w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p>From Harford County Public Schools:</p>
<p>Elizabeth White, Social Studies teacher at Harford Technical High School with 12 years of teaching experience for Harford County Public Schools (HCPS), was named the 2020 HCPS Teacher of the Year during a surprise announcement at the 26th Annual, and first ever virtual, Harford County Teacher of the Year Event. </p>
<p>The event was hosted for over 200 invited guests. Superintendent of Schools Dr. Sean Bulson, made the announcement Thursday evening to invited guests from all over the county, including elected officials, school administrators, educators, students, family, friends, and community sponsors.</p>
<p>“This event provides an opportunity for the Harford County community to come together, in a very unique way this year, to celebrate the teaching profession,” said Dr. Bulson.</p>
<p> “We shine the spotlight on five outstanding finalists. Right now, these finalists and teachers throughout the system are illustrating what our educators mean to our community. They are showing us that educators aren’t just in our classrooms as they currently work to instruct, support, and encourage our students remotely. You can see each day on her social media accounts why Mrs. White has earned this title; even during everything going on in the world around us, Mrs. White is ensuring her students know she’s here for them. I encourage you to follow her on social media through the upcoming year and I’m proud to announce Mrs. White as Harford County’s 2020 Teacher of the Year.”</p>
<p>Mrs. White began her career with Harford County Public Schools in 2009 at Edgewood High School, and currently teaches at Harford Technical High School. She was the cowinner of an HCPS curriculum award in 2015 and is currently working towards National Board certification. She is dedicated to her school community through her work with the Student Government Association at Harford Technical High School and has coached students, mentored future teachers, and served as a member of the Maryland Environmental Literacy Partnership. Mrs. White has also served the Social Studies and Technology offices to provide professional development and in the creation of new curricula and assessments.</p>
<p>Mrs. White earned a Bachelor of Science in History with a concentration in Secondary Education from Towson University in 2008, and a Masters in Instructional Leadership and Professional Development in 2009. Mrs. White was nominated for Harford County’s Teacher of the Year by colleague Amanda Roberts, a Harford County Public Schools 2018 Teacher of the Year finalist.</p>
<p>“Beth teaches primarily history. This subject is usually not the most exciting to a typical high school student, but Beth creates such authentic and engaging lessons that students cannot help but be interested in what they’re learning,” said nominator, Amanda Roberts. “Beth is a far cry away from your typical history lecturer. She not only teaches them rich history content, but also academic and life skills that they can apply in a multitude of circumstances.”</p>
<p>Enthusiastic support for her nomination came from Mr. Joe Collins, principal of Harford Technical High School.</p>
<p>“Mrs. White is an expert in her content area, a master teacher, a champion of using technology to maximize learning and a devoted sponsor of Harford Tech’s Student Government Association,” said Mr. Collins. “She represents the high instructional expectations of Harford Tech and HCPS and is a role model of someone who loves what she does and expresses it every day in her classroom.”</p>
<p>As the Harford County Teacher of the Year, Mrs. White received a free lease of a brand new 2020 Nissan Rogue for one year courtesy of Jones Junction, a Dell laptop, a watch from Saxon’s Diamond Centers, a big-screen TV from NTA Life, and a custom ring from Jostens. In addition, she was awarded multiple gift certificates, local merchant gift cards, and $1,200 from HAR-CO Credit Union, which was provided to all five finalists.</p>
<p>Mrs. White will now compete for the title of Maryland Teacher of the Year to represent teachers across the state as an education spokesperson. We anticipate the state winner will be announced at the Maryland Teacher of the Year Gala in October.</p>
<p>Visit www.hcps.org for more information on 2020 HCPS Teacher of the Year Elizabeth White, as well as the other four Harford County Teacher of the Year finalists.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" data-text="Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year"  >Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2020%2F04%2F23%2Felizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year%2F&#038;media=http%3A%2F%2Fwww.daggerpress.com%2Fwp-content%2Fuploads%2FE12DA162-B4BE-43C9-8111-FEA533710F1D.jpeg&#038;description=Elizabeth%20White%2C%20Harford%20Tech%20Social%20Studies%20Teacher%2C%20Named%202020%20Harford%20County%20Teacher%20of%20the%20Year" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-112517-5ea25999a0c25' data-src='https://widgets.wp.com/likes/#blog_id=2163858&amp;post_id=112517&amp;origin=www.daggerpress.com&amp;obj_id=2163858-112517-5ea25999a0c25' data-name='like-post-frame-2163858-112517-5ea25999a0c25'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Dagger News Service</span></h4><div class="author-box-content" itemprop="description"><p>Send Us Your News<br />
<a href="mailto:tellus@daggerpress.com">tellus@daggerpress.com</a></p>
</div></section>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.daggerpress.com/wp-comments-post.php?wpe-comment-post=sp20183cbm0e7" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='112517' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="51f39f3a19" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="178"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.daggerpress.com/" role="search"><meta itemprop="target" content="http://www.daggerpress.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 420px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;That's why I don't take my cell phone every where I go I love my constitution privacy rights this isn't&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459112" title="heidi dudek | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>heidi dudek</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Brother could you spare some chloraquine?&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459104" title="? | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>?</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It's more like MisInfoWars….and I can tell.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459100" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Appropriate that a guy the shape of planet earth would share a message about planet earth.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459099" title="Sword of Light | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Sword of Light</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Trump acts like an asshole because the Democratic media keeps asking him question that make it look like he is&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459098" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Agreed, the Democratic treason this scumbag represents is disgusting....&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459096" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Michael Moore another winner.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459089" title="True Harford Republican | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>True Harford Republican</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;and free people sometimes take a risk to be free. Freedom doesn't come without consequence, however, unless you have tested&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459074" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Name a young person that has died without an underlying condition....from what I understand it goes thru them like a&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459073" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;A private entity can not abrogate your rights by contract. A contract is a creation of contract law, also known&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459072" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The differences here than 100 years ago is high speed travel, this virus leaves you contagious before symptoms and medical&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459071" title="Cdev | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Cdev</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Not if he worked at a fast food location in close proximity to a place that had a massive break&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459070" title="Cdev | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Cdev</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;The 4th ammendment is a limit on government not a private entity you enter into a contract with. They can&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459069" title="Cdev | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Cdev</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;He was 27 with underlying health conditions, which I don't know what the conditions were. He was not healthy and&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459065" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;A cellphone company does not have the authority to make a person trackable by a third party without a warrant.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459064" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Once again, my Democratic imitator is talking about a topic that no one cares about. The Russian hoax is in&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459063" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;How old was the person in this county that died.....BTW anyone know were he worked?&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459060" title="Cdev | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Cdev</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Well if you want to use thier cell service you play by thier rules....It was in your service agreement. This&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459059" title="Cdev | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Cdev</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;A Happy Earth Day message from award winning investigative reporter Michael Moore! https://www.youtube.com/watch?v=Zk11vI-7czE&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459058" title="Mike Callahan | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Mike Callahan</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Although the tactics employed by Russia vary from one campaign to the next, there are several consistent themes in the&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459057" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I agree he would be 1000 times better than the orange asshole&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459053" title="reality check | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>reality check</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;And once again the imitator of the SoulCrusher puts his Democratic treason out there on the Dagger. These last 2&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459052" title="SoulCrusher | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>SoulCrusher</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Joe Biden would not even know there was a virus. He cant even remember his name or what he is&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459050" title="True Harford Republican | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>True Harford Republican</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Good job Mike. Everyone is impressed. More talking points. Trump 2020&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459049" title="True Harford Republican | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>True Harford Republican</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Here is the documented facts about how Trump mishandled the Corona Virus! PBS's FrontLines film Corona Virus Pandemic: Washington (State}&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/#comment-459048" title="Mike Callahan | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”"><strong>Mike Callahan</strong> | Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section>
<section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
											<li>
					<a href="http://www.daggerpress.com/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" aria-current="page">Elizabeth White, Harford Tech Social Studies Teacher, Named 2020 Harford County Teacher of the Year</a>
											<span class="post-date">April 23, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/04/19/sen-cassilly-on-coronavirus-reality-of-the-situation-dictates-that-we-continue-to-make-these-economic-sacrifices-in-pursuit-of-the-greater-good/">Sen. Cassilly on Coronavirus: “Reality of the Situation Dictates that We Continue to Make these Economic Sacrifices in Pursuit of the Greater Good”</a>
											<span class="post-date">April 19, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/04/17/harfords-first-confirmed-covid-19-death-reported-test-results-pending-on-probable-deaths/">Harford’s First Confirmed COVID-19 Death Reported; Test Results Pending on “Probable Deaths”</a>
											<span class="post-date">April 17, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/27/havre-de-grace-teen-brothers-charged-with-attempted-murder-robbery/">Havre de Grace Teen Brothers Charged with Attempted Murder &#038; Robbery</a>
											<span class="post-date">March 27, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/26/bel-air-burglar-slashed-by-resident-during-attempted-home-invasion/">Bel Air Burglar Slashed By Resident During Attempted Home Invasion</a>
											<span class="post-date">March 26, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/24/61-yr-old-woman-killed-in-single-vehicle-darlington-crash/">61-Yr-Old Woman Killed in Single-Vehicle Darlington Crash</a>
											<span class="post-date">March 24, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/19/superintendent-bulson-hcps-is-not-equipped-to-deliver-comprehensive-online-instruction-to-our-students/">Superintendent Bulson: “HCPS is Not Equipped to Deliver Comprehensive Online Instruction to Our Students”</a>
											<span class="post-date">March 19, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/16/harford-county-public-schools-to-provide-meals-during-emergency-closure/">Harford County Public Schools to Provide Meals During Emergency Closure</a>
											<span class="post-date">March 16, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/14/2nd-coronavirus-case-confirmed-in-harford-county-69-yr-old-relative-of-1st-case/">2nd Coronavirus Case Confirmed in Harford County; 69-Yr-Old Relative of 1st Case</a>
											<span class="post-date">March 14, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/13/harford-county-public-library-to-close-all-branches-through-march/">Harford County Public Library to Close All Branches Through March</a>
											<span class="post-date">March 13, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/12/harford-county-public-schools-to-close-march-16-27-as-coronavirus-precaution/">Harford County Public Schools to Close March 16-27 as Coronavirus Precaution</a>
											<span class="post-date">March 12, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/12/harford-county-senior-centers-to-close-march-13-as-precaution-against-coronavirus/">Harford County Senior Centers to Close March 13 as Precaution Against Coronavirus</a>
											<span class="post-date">March 12, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/10/harford-county-public-schools-takes-measures-against-coronavirus/">Harford County Public Schools Takes Measures Against Coronavirus</a>
											<span class="post-date">March 10, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/09/county-executive-glassman-urges-public-to-stay-calm-stay-informed-following-coronavirus-case-in-harford/">County Executive Glassman Urges Public to Stay Calm, Stay Informed Following Coronavirus Case in Harford</a>
											<span class="post-date">March 9, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/08/coronavirus-in-harford-woman-tests-positive-county-executive-to-hold-press-conference/">Coronavirus in Harford: Woman Tests Positive; County Executive to Hold Press Conference</a>
											<span class="post-date">March 8, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/03/06/stop-sign-violation-leads-to-handgun-and-drug-arrest-in-aberdeen/">Stop Sign Violation Leads to Handgun and Drug Arrest in Aberdeen</a>
											<span class="post-date">March 6, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/02/26/harford-county-public-schools-updates-parents-on-coronavirus/">Harford County Public Schools Updates Parents on Coronavirus</a>
											<span class="post-date">February 26, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/02/24/shots-fired-call-leads-to-arrests-for-weapons-violations-in-aberdeen/">Shots Fired Call Leads to Arrests for Weapons Violations in Aberdeen</a>
											<span class="post-date">February 24, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/02/20/bel-air-police-chief-criminal-allegations-dismissed/">Bel Air Police Chief Criminal Allegations Dismissed</a>
											<span class="post-date">February 20, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/02/17/harford-executive-glassman-proposes-phase-in-of-kirwan-recommendations-in-baltimore-city-raising-teacher-salaries-statewide/">Harford Executive Glassman Proposes Phase-in of Kirwan Recommendations in Baltimore City, Raising Teacher Salaries Statewide</a>
											<span class="post-date">February 17, 2020</span>
									</li>
					</ul>
		</div></section>
</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2020/04/'> April 2020 &nbsp;(3)</option>
	<option value='http://www.daggerpress.com/2020/03/'> March 2020 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2020/02/'> February 2020 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2020/01/'> January 2020 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/12/'> December 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/11/'> November 2019 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/10/'> October 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/09/'> September 2019 &nbsp;(11)</option>
	<option value='http://www.daggerpress.com/2019/08/'> August 2019 &nbsp;(6)</option>
	<option value='http://www.daggerpress.com/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2019/06/'> June 2019 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2019/05/'> May 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/04/'> April 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/03/'> March 2019 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2019/02/'> February 2019 &nbsp;(21)</option>
	<option value='http://www.daggerpress.com/2019/01/'> January 2019 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/12/'> December 2018 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2018/11/'> November 2018 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2018/10/'> October 2018 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2018/09/'> September 2018 &nbsp;(31)</option>
	<option value='http://www.daggerpress.com/2018/08/'> August 2018 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2018/07/'> July 2018 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/06/'> June 2018 &nbsp;(36)</option>
	<option value='http://www.daggerpress.com/2018/05/'> May 2018 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2018/04/'> April 2018 &nbsp;(50)</option>
	<option value='http://www.daggerpress.com/2018/03/'> March 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/02/'> February 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/01/'> January 2018 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2017/12/'> December 2017 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2017/11/'> November 2017 &nbsp;(45)</option>
	<option value='http://www.daggerpress.com/2017/10/'> October 2017 &nbsp;(57)</option>
	<option value='http://www.daggerpress.com/2017/09/'> September 2017 &nbsp;(42)</option>
	<option value='http://www.daggerpress.com/2017/08/'> August 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/07/'> July 2017 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2017/06/'> June 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/05/'> May 2017 &nbsp;(84)</option>
	<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/daggerpress" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/daggerpress"><a href="https://www.facebook.com/daggerpress"></a></blockquote></div>
		</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2020 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer>	<div style="display:none">
	<div class="grofile-hash-map-9943ada0a4ac662b8adc37ee7819c8c9">
	</div>
	</div>
<style type="text/css" media="screen"></style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2020\/04\/23\/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year\/":112517};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2020/04/23/elizabeth-white-harford-tech-social-studies-teacher-named-2020-harford-county-teacher-of-the-year/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.daggerpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202017'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_ulike_params = {"ajax_url":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","notifications":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=3.5.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.8.1'></script>
<script async="async" type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202017#ver=202017' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202017.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'2163858',post:'112517',tz:'-4',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '112517' ]);
</script>
</body></html>
