<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Feed" href="http://www.daggerpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Comments Feed" href="http://www.daggerpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dagger - Local News with an Edge &raquo; Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event Comments Feed" href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/feed/" />
<link rel="canonical" href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.daggerpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='metro-pro-theme-css'  href='http://www.daggerpress.com/wp-content/themes/metro-pro/style.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.daggerpress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-ulike-css'  href='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=3.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.0' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.daggerpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21' id='svg-x-use-js'></script>
<link rel="https://api.w.org/" href="http://www.daggerpress.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.daggerpress.com/wp-json/wp/v2/posts/113050" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.daggerpress.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2021%2F05%2F05%2Fharford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.daggerpress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.daggerpress.com%2F2021%2F05%2F05%2Fharford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.daggerpress.com/wp-content/themes/metro-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.daggerpress.com/wp-content/uploads/cropped-dagnewheadnew2_2014.jpg) no-repeat !important; }</style>
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
googletag.defineSlot('/73551097/Dagger_Sidebar_300x250_All', [300, 250], 'div-gpt-ad-1361367207158-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><style>body { background-color: #ffffff; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event" />
<meta property="og:url" content="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" />
<meta property="og:description" content="From the Harford County Chamber of Commerce: On Thursday, April 25th, the Harford County Chamber of Commerce hosted its Annual Legislative Wrap-Up in a virtual format, sponsored by Harford Communit…" />
<meta property="article:published_time" content="2021-05-06T02:56:45+00:00" />
<meta property="article:modified_time" content="2021-05-06T02:58:36+00:00" />
<meta property="og:site_name" content="The Dagger - Local News with an Edge" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<!-- BEGIN GADWP v5.1.1.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-445494-10', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
			<style type="text/css" id="wp-custom-css">
				@import  "http://fonts.googleapis.com/css?family=Droid+Sans";

/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/
/* Import Fonts
------------------------------------------------------------ */
.entry-title {
	font-size: 3.2rem;
	font-weight: 800;
}

.after-entry .widget-title, .archive-title, .comments-title, .widget .entry-title {
	font-size: 1.5rem;
}

.title-area {
	float: left;
	padding: 0;
	width: 302px;
}

.header-image .site-title a {
	background-color: none;
	max-width: 302px;
	min-height: 80px;
	padding: 0;
}

.site-header .widget-area {
	float: right;
	width: 728px;
}

.breadcrumb {
	font-size: 1.2rem;
}

@media only screen and (max-width: 728px) {
	.title-area {
		width: 100%;
	}
	
	.site-header .widget-area {
		width: 100%;
	}
}

body {
	font-family: 'Droid Sans', sans-serif;
}

blockquote, blockquote::before {
	color: #555;
}			</style>
		</head>
<body class="post-template-default single single-post postid-113050 single-format-standard custom-background custom-header header-image content-sidebar metro-pro-red" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-87194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url"><span itemprop="name">About The Dagger</span></a></li>
<li id="menu-item-87191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-87195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-87192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-87193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url"><span itemprop="name">Terms of Service</span></a></li>
</ul></div></nav><div class="site-container"><div align="center"><a href="http://ad.broadstreetads.com/zone_static/23798/click/0"><img src="http://ad.broadstreetads.com/zone_static/23798/image/0"/></a></div> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.daggerpress.com/">The Dagger - Local News with an Edge</a></p></div><div class="widget-area header-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://ad.broadstreetads.com/zone_static/9951/click/0"><img src="http://ad.broadstreetads.com/zone_static/9951/image/0"/></a>

		</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-12459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12459"><a title="Local" href="/category/local-ink/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-12460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12460"><a title="Politics" href="/category/the-dirt/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-12461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12461"><a title="Schools" href="/category/the-school-yard/" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-12462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12462"><a title="Sirens" href="/category/sirens/" itemprop="url"><span itemprop="name">Sirens</span></a></li>
<li id="menu-item-14705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14705"><a title="Health/Food" href="http://www.daggerpress.com/category/food/" itemprop="url"><span itemprop="name">Health/Food</span></a></li>
<li id="menu-item-14703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14703"><a title="Arts &#038; Entertainment" href="http://www.daggerpress.com/category/pop-culture/" itemprop="url"><span itemprop="name">A&#038;E</span></a></li>
<li id="menu-item-93954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93954"><a title="Sports" href="http://www.daggerpress.com/category/balls/" itemprop="url"><span itemprop="name">Sports</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a href="http://www.daggerpress.com/category/local-ink/" itemprop="item"><span itemprop="name">Local</span></a></span> <span aria-label="breadcrumb separator">/</span> Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event</div><article class="post-113050 post type-post status-publish format-standard category-local-ink category-the-dirt entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-05-05T22:56:45-04:00">May 5, 2021</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.daggerpress.com/author/daggernews/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Dagger News Service</span></a></span> <span class="entry-comments-link"><a href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p>From the Harford County Chamber of Commerce:</p>
<p>On Thursday, April 25th, the Harford County Chamber of Commerce hosted its Annual Legislative Wrap-Up in a virtual format, sponsored by Harford Community College, The Harford County Office of Community and Economic Development, and The Greater Harford Committee. Dr. Theresa Felder, President and CEO of Harford Community College, said in her introductory remarks, “Harford Community College is honored to have a strong relationship with the business community as well as with our partners in both the public and private sectors.”</p>
<p>The event featured the Maryland General Assembly’s Harford County Delegation which included Senators Bob Cassilly, J.B. Jennings, and Jason Gallion, and Delegates Susan McComas, Lauren Arikan, Steve Johnson, Mary Ann Lisanti, Mike Griffith and Kathy Szeliga. Delegates Teresa Reilly and Rick Impallaria were unable to attend due to scheduling conflicts.</p>
<p>Each legislator discussed their experience during the 2021 Session, and then responded to questions. </p>
<p>Delegate Arikan, Judiciary Committee member, worked with speaker’s office to amend police reform bills. On evictions, Del. Arikan discussed new legislation that will make temporary Governor’s orders law, causing potential problems for landlords and renters.</p>
<p>Senator Cassilly highlighted that 20 million dollars is now set for capitol improvements in Harford, including education and Route 40 revitalization projects. He urged the importance of public safety in Harford, and that local officials fully fund the State’s Attorney and Sheriff’s Office.</p>
<p>Senator Gallion expressed his support for the Governor’s COVID relief bills. He brought up the issue of lack of broadband in some areas of Harford County. Broadband Senate Bill 66 plans to have affordable, reliable broadband across the state by 2026. Gallion supported Governor Hogan’s vetoes on the additional tax of tobacco and digital advertising and downloads-bills that were then overridden.</p>
<p>Delegate Szeliga echoed that the COVID relief bills passed helped local businesses and unemployed workers. She believes students should be back to complete in-person learning as soon as possible, after facing many challenges with virtual learning including internet accessibility issues.</p>
<p>The 2021 Maryland General Assembly Session created new challenges, explained Senator Jennings. The Senate and the House were isolated, there was no outside interaction, and only six individuals were allowed to testify on issues – three in support and three in opposition of a bill.</p>
<p>Delegate Lisanti, also in support of the new relief package, stated that it would help individuals get back to school and work. One size doesn’t fit all for education and public safety, she explained. Curriculums are being micro-managed without taking specific populations needs into account. The new police reform bills take away the ability for local jurisdictions to deal with their officers.</p>
<p>Delegate Johnson agreed that this session was particularly difficult given the lack of opportunities for in-person meetings and conversations that organically happen between legislators and bill supporters/opponents. He also discussed that COVID exposed weaknesses in healthcare and (through necessity) proved that telehealth is a successful adaptation.</p>
<p>Delegate Griffith fought to protect special needs of children this session, getting HB716 passed so that all IEP Evaluations must be conducted in person. He said he also secured additional funding for Harford County, some of which will be used to complete the Ma &#038; Pa Trail.</p>
<p>Sitting on the Rules Committee, Delegate McComas said that much of the legislation she supported did not make it to the floor. She said a lack of representation and testimonies for issues caused difficulty in trying to pass legislation.</p>
<p>In closing, legislators urged local businesses and organizations to share how upcoming legislation would impact them by contacting the committees that the particular bills would pass through.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" data-text="Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event"  >Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" data-counter="right"></script></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.daggerpress.com%2F2021%2F05%2F05%2Fharford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event%2F&#038;media=http%3A%2F%2F0.gravatar.com%2Favatar%2F9943ada0a4ac662b8adc37ee7819c8c9%3Fs%3D96%26d%3Dmm%26r%3Dg&#038;description=Harford%20Legislators%20Address%20Business%20Community%20at%20Harford%20%20Chamber%E2%80%99s%20Legislative%20Wrap-Up%20Event" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2163858-113050-609806fda39aa' data-src='https://widgets.wp.com/likes/#blog_id=2163858&amp;post_id=113050&amp;origin=www.daggerpress.com&amp;obj_id=2163858-113050-609806fda39aa' data-name='like-post-frame-2163858-113050-609806fda39aa'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9943ada0a4ac662b8adc37ee7819c8c9?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' loading='lazy'/><h4 class="author-box-title">About <span itemprop="name">Dagger News Service</span></h4><div class="author-box-content" itemprop="description"><p>Send Us Your News<br />
<a href="mailto:tellus@daggerpress.com">tellus@daggerpress.com</a></p>
</div></section>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.daggerpress.com/wp-comments-post.php?wpe-comment-post=sp20183cbm0e7" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='113050' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="69064c70bf" /></p><input type="hidden" id="ak_js" name="ak_js" value="211"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.daggerpress.com/" role="search"><meta itemprop="target" content="http://www.daggerpress.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">		<h4 class="widget-title widgettitle">Sounding Off</h4>
			<div style="overflow: auto; height: 1220px;">
			<ul class="recent-comment" style="margin:0 2px;">
									<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;OYE....Over the last year I have had my “thin blue line” garden flag stolen with its metal holder. It was&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474573" title="WhatMattersisBlue | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>WhatMattersisBlue</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Approximately one month ago I was contacted by a woman in my church about a civil or small claims issue&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474565" title="Open Your Eyes | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Open Your Eyes</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I'll be impressed if Hogan could just talk him into getting a hair cut.&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474558" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Maryland Gov. Larry Hogan and Baltimore Mayor Brandon Scott to discuss city crime" https://www.baltimoresun.com/politics/bs-md-ci-hogan-scott-meeting-crime-20210505-2ofhgwor5jbrng3dzzqro6rcyi-story.html It's critical that both gentlemen set&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474493" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Makes no sense because the police and the courts are ALL part of the Judicial Department. Basically the stupid Judge&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474452" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Chief judge of Maryland District Courts bans staff from wearing ‘thin blue line’ face masks and other items" https://www.baltimoresun.com/news/crime/bs-prem-md-ci-cr-thin-blue-line-masks-20210506-wy57ocixwnfvtoqxl6ijko3g4a-story.html&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474445" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Republican and Independents should NOT reach out across the aisle and need to BLOCK ALL LEGISLATION the Democratic Traitors Against&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474437" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Bob thanks for the information. I have always thought, “What is written is believed.” I think that I have reached&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474406" title="WhatMattersisBlue | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>WhatMattersisBlue</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Uh, the entire Russia Investigation was FAKE NEWS and it went on for 3 years by the FAKE NEWS MEDIA!&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474402" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Hello Blue, I hope this post finds you in good health and high spirits. According to the below AP News&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474401" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;Bob, you are obviously a loyal Democrat, but doesn’t any of this bother you? What in the world is Hunter&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474398" title="WhatMattersisBlue | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>WhatMattersisBlue</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;“Change your mindset” if you would could you please explain further exactly what you mean. Before I jump to any&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474394" title="Open Your Eyes | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Open Your Eyes</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;OYE, let's cut to the chase. Suffice it to say. It's highly unlikely that any "liberals or Democrats" on this&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474390" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I don't even want an explanation from them. I gotten to the point where I cringe every time I hear&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474386" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I’m still waiting for liberals or Democrats to offer some type rational justification for such despicable hypocritical behavior. Please explain&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474358" title="Open Your Eyes | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Open Your Eyes</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It is illegal for D.C. to become a State. That which is unconstitutional is illegal because the Constitution is the&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474336" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"DC statehood: Why it should (and should not) happen" https://www.cnn.com/2021/04/23/politics/washington-dc-statehood-101/index.html&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474327" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Mitch McConnell draws a red line at $600 billion for infrastructure and jobs — and says Trump tax cuts are&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474319" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It is unconstitutional for Washington D.C. to become a State. It's purpose is literally engrained in our Constitution under Article&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474317" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;You know I have said it before and I will be graphically vulgar again. One thing that really irritates me&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474296" title="Open Your Eyes | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Open Your Eyes</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;If I had the talent to design clothing, I would produce jackets and sweats made with space blanket material. Oops!&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474272" title="WhatMattersisBlue | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>WhatMattersisBlue</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;He has said he wouldn't support other things, but once he was bribed by the rest of the Democratic "Not&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474257" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;"Manchin deals DC statehood -- and Dems -- another blow" https://www.foxnews.com/politics/manchin-pans-dc-statehood-bill-break-dems This guy is, and likely, will continue to be&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474252" title="Bob | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>Bob</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;I think we can all see who really needs to be defunded and it isn't the police. If we could&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474180" title="SoulCrusher | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>SoulCrusher</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
								<li style="list-style:none; padding-bottom:0;border-bottom:0;">
					<p><em>&ldquo;It is sad that some leaders in government, sports, entertainment, and MSM haven’t figured out the sacrifice made by Police.&hellip;&rdquo;</em></p>
					<p style="font-family:Helvetica,Arial; font-size:0.8em; color:#555;list-style: none;"><a style="color:#880000;" href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/#comment-474134" title="WhatMattersisBlue | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;"><strong>WhatMattersisBlue</strong> | Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a></p>
				</li>
							</ul>
			</div>

</div>
		</div></section>
<section id="text-28" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center"><script type="text/javascript">broadstreet.zone(9952);</script></div></div>
		</div></section>

		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">
		<h4 class="widget-title widgettitle">Recent Posts</h4>

		<ul>
											<li>
					<a href="http://www.daggerpress.com/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" aria-current="page">Harford Legislators Address Business Community at Harford  Chamber’s Legislative Wrap-Up Event</a>
											<span class="post-date">May 5, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/04/21/hickory-elementarys-lauren-byrd-named-2021-harford-county-teacher-of-the-year/">Hickory Elementary&#8217;s Lauren Byrd Named 2021 Harford County Teacher of the Year</a>
											<span class="post-date">April 21, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/04/19/police-investigate-edgewood-shooting-and-car-crash/">Police Investigate Edgewood Shooting and Car Crash</a>
											<span class="post-date">April 19, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/04/15/harford-county-executive-glassman-announces-run-for-state-comptroller/">Harford County Executive Glassman Announces Run for State Comptroller</a>
											<span class="post-date">April 15, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/03/01/bel-air-man-baltimore-swat-officer-faces-child-pornography-charges/">Bel Air Man, Baltimore SWAT Officer, Faces Child Pornography Charges</a>
											<span class="post-date">March 1, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/02/26/havre-de-grace-man-arrested-for-sexual-solicitation-of-a-minor-in-cecil-county/">Havre de Grace Man Arrested for Sexual Solicitation of a Minor in Cecil County</a>
											<span class="post-date">February 26, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/02/03/as-hcps-accelerates-elementary-students-return-vaccinations-for-secondary-teachers-canceled-due-to-lack-of-supply/">As HCPS Accelerates Elementary Students’ Return, Vaccinations for Secondary Teachers Canceled Due to Lack of Supply</a>
											<span class="post-date">February 3, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/01/13/harford-county-sheriff-gahler-if-you-choose-to-exercise-your-constitutional-right-to-participate-in-any-planned-protest-i-implore-you-to-do-so-peacefully/">Harford County Sheriff Gahler: “If You Choose to Exercise Your Constitutional Right to Participate in any Planned Protest, I Implore You to do so Peacefully”</a>
											<span class="post-date">January 13, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/01/07/rep-harris-some-marylanders-are-even-calling-for-my-resignation-which-i-will-not-do/">Rep. Harris: “Some Marylanders are Even Calling for My Resignation, Which I Will Not Do”</a>
											<span class="post-date">January 7, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2021/01/05/cause-of-fire-in-vacant-havre-de-grace-house-under-investigation/">Cause of Fire in Vacant Havre de Grace House Under Investigation</a>
											<span class="post-date">January 5, 2021</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/12/30/police-investigate-separate-fatal-crashes-in-bel-air-and-street/">Police Investigate Separate Fatal Crashes in Bel Air and Street</a>
											<span class="post-date">December 30, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/12/27/armed-robbery-suspect-fleeing-police-dies-of-apparent-self-inflicted-gunshot-wound/">Armed Robbery Suspect Fleeing Police Dies of Apparent Self-Inflicted Gunshot Wound</a>
											<span class="post-date">December 27, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/12/22/harford-county-democratic-central-committee-opposes-further-militarizing-the-police/">Harford County Democratic Central Committee Opposes &#8220;Further Militarizing the Police&#8221;</a>
											<span class="post-date">December 22, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/12/15/middle-river-man-22-killed-in-edgewood-shooting/">Middle River Man, 22, Killed in Edgewood Shooting</a>
											<span class="post-date">December 15, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/12/12/man-injured-in-havre-de-grace-shooting/">Man Injured in Havre de Grace Shooting</a>
											<span class="post-date">December 12, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/11/20/woman-killed-in-aberdeen-house-fire/">Woman Killed in Aberdeen House Fire</a>
											<span class="post-date">November 20, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/11/18/detectives-investigate-edgewood-murder-suicide/">Detectives Investigate Edgewood Murder-Suicide</a>
											<span class="post-date">November 18, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/11/12/harford-county-clamps-back-down-after-covid-19-surge/">Harford County Clamps Back Down After COVID-19 Surge</a>
											<span class="post-date">November 12, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/11/12/conowingo-dam-sediment-characterization-study-begins/">Conowingo Dam Sediment Characterization Study Begins</a>
											<span class="post-date">November 12, 2020</span>
									</li>
											<li>
					<a href="http://www.daggerpress.com/2020/11/06/former-baltimore-police-detective-from-bel-air-pleads-guilty-to-making-false-statements-to-federal-agents/">Former Baltimore Police Detective, from Bel Air, Pleads Guilty to Making False Statements to Federal Agents</a>
											<span class="post-date">November 6, 2020</span>
									</li>
					</ul>

		</div></section>
</aside></div></div><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-290Df5IJdBpO2"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-290Df5IJdBpO2.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="archives-3" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='http://www.daggerpress.com/2021/05/'> May 2021 &nbsp;(1)</option>
	<option value='http://www.daggerpress.com/2021/04/'> April 2021 &nbsp;(3)</option>
	<option value='http://www.daggerpress.com/2021/03/'> March 2021 &nbsp;(1)</option>
	<option value='http://www.daggerpress.com/2021/02/'> February 2021 &nbsp;(2)</option>
	<option value='http://www.daggerpress.com/2021/01/'> January 2021 &nbsp;(3)</option>
	<option value='http://www.daggerpress.com/2020/12/'> December 2020 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2020/11/'> November 2020 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2020/10/'> October 2020 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2020/09/'> September 2020 &nbsp;(3)</option>
	<option value='http://www.daggerpress.com/2020/08/'> August 2020 &nbsp;(3)</option>
	<option value='http://www.daggerpress.com/2020/07/'> July 2020 &nbsp;(8)</option>
	<option value='http://www.daggerpress.com/2020/06/'> June 2020 &nbsp;(11)</option>
	<option value='http://www.daggerpress.com/2020/05/'> May 2020 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2020/04/'> April 2020 &nbsp;(8)</option>
	<option value='http://www.daggerpress.com/2020/03/'> March 2020 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2020/02/'> February 2020 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2020/01/'> January 2020 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/12/'> December 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/11/'> November 2019 &nbsp;(9)</option>
	<option value='http://www.daggerpress.com/2019/10/'> October 2019 &nbsp;(12)</option>
	<option value='http://www.daggerpress.com/2019/09/'> September 2019 &nbsp;(11)</option>
	<option value='http://www.daggerpress.com/2019/08/'> August 2019 &nbsp;(6)</option>
	<option value='http://www.daggerpress.com/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='http://www.daggerpress.com/2019/06/'> June 2019 &nbsp;(7)</option>
	<option value='http://www.daggerpress.com/2019/05/'> May 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/04/'> April 2019 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2019/03/'> March 2019 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2019/02/'> February 2019 &nbsp;(21)</option>
	<option value='http://www.daggerpress.com/2019/01/'> January 2019 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/12/'> December 2018 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2018/11/'> November 2018 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2018/10/'> October 2018 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2018/09/'> September 2018 &nbsp;(31)</option>
	<option value='http://www.daggerpress.com/2018/08/'> August 2018 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2018/07/'> July 2018 &nbsp;(33)</option>
	<option value='http://www.daggerpress.com/2018/06/'> June 2018 &nbsp;(36)</option>
	<option value='http://www.daggerpress.com/2018/05/'> May 2018 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2018/04/'> April 2018 &nbsp;(50)</option>
	<option value='http://www.daggerpress.com/2018/03/'> March 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/02/'> February 2018 &nbsp;(56)</option>
	<option value='http://www.daggerpress.com/2018/01/'> January 2018 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2017/12/'> December 2017 &nbsp;(34)</option>
	<option value='http://www.daggerpress.com/2017/11/'> November 2017 &nbsp;(45)</option>
	<option value='http://www.daggerpress.com/2017/10/'> October 2017 &nbsp;(57)</option>
	<option value='http://www.daggerpress.com/2017/09/'> September 2017 &nbsp;(42)</option>
	<option value='http://www.daggerpress.com/2017/08/'> August 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/07/'> July 2017 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2017/06/'> June 2017 &nbsp;(61)</option>
	<option value='http://www.daggerpress.com/2017/05/'> May 2017 &nbsp;(84)</option>
	<option value='http://www.daggerpress.com/2017/04/'> April 2017 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2017/03/'> March 2017 &nbsp;(89)</option>
	<option value='http://www.daggerpress.com/2017/02/'> February 2017 &nbsp;(66)</option>
	<option value='http://www.daggerpress.com/2017/01/'> January 2017 &nbsp;(67)</option>
	<option value='http://www.daggerpress.com/2016/12/'> December 2016 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2016/11/'> November 2016 &nbsp;(54)</option>
	<option value='http://www.daggerpress.com/2016/10/'> October 2016 &nbsp;(70)</option>
	<option value='http://www.daggerpress.com/2016/09/'> September 2016 &nbsp;(72)</option>
	<option value='http://www.daggerpress.com/2016/08/'> August 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/07/'> July 2016 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2016/06/'> June 2016 &nbsp;(75)</option>
	<option value='http://www.daggerpress.com/2016/05/'> May 2016 &nbsp;(93)</option>
	<option value='http://www.daggerpress.com/2016/04/'> April 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/03/'> March 2016 &nbsp;(87)</option>
	<option value='http://www.daggerpress.com/2016/02/'> February 2016 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2016/01/'> January 2016 &nbsp;(79)</option>
	<option value='http://www.daggerpress.com/2015/12/'> December 2015 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2015/11/'> November 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/10/'> October 2015 &nbsp;(95)</option>
	<option value='http://www.daggerpress.com/2015/09/'> September 2015 &nbsp;(96)</option>
	<option value='http://www.daggerpress.com/2015/08/'> August 2015 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2015/07/'> July 2015 &nbsp;(78)</option>
	<option value='http://www.daggerpress.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2015/05/'> May 2015 &nbsp;(83)</option>
	<option value='http://www.daggerpress.com/2015/04/'> April 2015 &nbsp;(113)</option>
	<option value='http://www.daggerpress.com/2015/03/'> March 2015 &nbsp;(98)</option>
	<option value='http://www.daggerpress.com/2015/02/'> February 2015 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2015/01/'> January 2015 &nbsp;(108)</option>
	<option value='http://www.daggerpress.com/2014/12/'> December 2014 &nbsp;(86)</option>
	<option value='http://www.daggerpress.com/2014/11/'> November 2014 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2014/10/'> October 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2014/09/'> September 2014 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2014/08/'> August 2014 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2014/07/'> July 2014 &nbsp;(94)</option>
	<option value='http://www.daggerpress.com/2014/06/'> June 2014 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2014/05/'> May 2014 &nbsp;(99)</option>
	<option value='http://www.daggerpress.com/2014/04/'> April 2014 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2014/03/'> March 2014 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2014/02/'> February 2014 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2014/01/'> January 2014 &nbsp;(109)</option>
	<option value='http://www.daggerpress.com/2013/12/'> December 2013 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2013/11/'> November 2013 &nbsp;(110)</option>
	<option value='http://www.daggerpress.com/2013/10/'> October 2013 &nbsp;(107)</option>
	<option value='http://www.daggerpress.com/2013/09/'> September 2013 &nbsp;(116)</option>
	<option value='http://www.daggerpress.com/2013/08/'> August 2013 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2013/07/'> July 2013 &nbsp;(125)</option>
	<option value='http://www.daggerpress.com/2013/06/'> June 2013 &nbsp;(117)</option>
	<option value='http://www.daggerpress.com/2013/05/'> May 2013 &nbsp;(130)</option>
	<option value='http://www.daggerpress.com/2013/04/'> April 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/03/'> March 2013 &nbsp;(147)</option>
	<option value='http://www.daggerpress.com/2013/02/'> February 2013 &nbsp;(138)</option>
	<option value='http://www.daggerpress.com/2013/01/'> January 2013 &nbsp;(144)</option>
	<option value='http://www.daggerpress.com/2012/12/'> December 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/11/'> November 2012 &nbsp;(118)</option>
	<option value='http://www.daggerpress.com/2012/10/'> October 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/09/'> September 2012 &nbsp;(115)</option>
	<option value='http://www.daggerpress.com/2012/08/'> August 2012 &nbsp;(119)</option>
	<option value='http://www.daggerpress.com/2012/07/'> July 2012 &nbsp;(123)</option>
	<option value='http://www.daggerpress.com/2012/06/'> June 2012 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2012/05/'> May 2012 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2012/04/'> April 2012 &nbsp;(146)</option>
	<option value='http://www.daggerpress.com/2012/03/'> March 2012 &nbsp;(164)</option>
	<option value='http://www.daggerpress.com/2012/02/'> February 2012 &nbsp;(161)</option>
	<option value='http://www.daggerpress.com/2012/01/'> January 2012 &nbsp;(122)</option>
	<option value='http://www.daggerpress.com/2011/12/'> December 2011 &nbsp;(104)</option>
	<option value='http://www.daggerpress.com/2011/11/'> November 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/10/'> October 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/09/'> September 2011 &nbsp;(151)</option>
	<option value='http://www.daggerpress.com/2011/08/'> August 2011 &nbsp;(136)</option>
	<option value='http://www.daggerpress.com/2011/07/'> July 2011 &nbsp;(142)</option>
	<option value='http://www.daggerpress.com/2011/06/'> June 2011 &nbsp;(139)</option>
	<option value='http://www.daggerpress.com/2011/05/'> May 2011 &nbsp;(150)</option>
	<option value='http://www.daggerpress.com/2011/04/'> April 2011 &nbsp;(152)</option>
	<option value='http://www.daggerpress.com/2011/03/'> March 2011 &nbsp;(174)</option>
	<option value='http://www.daggerpress.com/2011/02/'> February 2011 &nbsp;(141)</option>
	<option value='http://www.daggerpress.com/2011/01/'> January 2011 &nbsp;(132)</option>
	<option value='http://www.daggerpress.com/2010/12/'> December 2010 &nbsp;(124)</option>
	<option value='http://www.daggerpress.com/2010/11/'> November 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/10/'> October 2010 &nbsp;(126)</option>
	<option value='http://www.daggerpress.com/2010/09/'> September 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/08/'> August 2010 &nbsp;(97)</option>
	<option value='http://www.daggerpress.com/2010/07/'> July 2010 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2010/06/'> June 2010 &nbsp;(106)</option>
	<option value='http://www.daggerpress.com/2010/05/'> May 2010 &nbsp;(88)</option>
	<option value='http://www.daggerpress.com/2010/04/'> April 2010 &nbsp;(105)</option>
	<option value='http://www.daggerpress.com/2010/03/'> March 2010 &nbsp;(121)</option>
	<option value='http://www.daggerpress.com/2010/02/'> February 2010 &nbsp;(82)</option>
	<option value='http://www.daggerpress.com/2010/01/'> January 2010 &nbsp;(85)</option>
	<option value='http://www.daggerpress.com/2009/12/'> December 2009 &nbsp;(58)</option>
	<option value='http://www.daggerpress.com/2009/11/'> November 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2009/10/'> October 2009 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2009/09/'> September 2009 &nbsp;(101)</option>
	<option value='http://www.daggerpress.com/2009/08/'> August 2009 &nbsp;(49)</option>
	<option value='http://www.daggerpress.com/2009/07/'> July 2009 &nbsp;(46)</option>
	<option value='http://www.daggerpress.com/2009/06/'> June 2009 &nbsp;(63)</option>
	<option value='http://www.daggerpress.com/2009/05/'> May 2009 &nbsp;(69)</option>
	<option value='http://www.daggerpress.com/2009/04/'> April 2009 &nbsp;(102)</option>
	<option value='http://www.daggerpress.com/2009/03/'> March 2009 &nbsp;(90)</option>
	<option value='http://www.daggerpress.com/2009/02/'> February 2009 &nbsp;(81)</option>
	<option value='http://www.daggerpress.com/2009/01/'> January 2009 &nbsp;(65)</option>
	<option value='http://www.daggerpress.com/2008/12/'> December 2008 &nbsp;(40)</option>
	<option value='http://www.daggerpress.com/2008/11/'> November 2008 &nbsp;(60)</option>
	<option value='http://www.daggerpress.com/2008/10/'> October 2008 &nbsp;(92)</option>
	<option value='http://www.daggerpress.com/2008/09/'> September 2008 &nbsp;(68)</option>
	<option value='http://www.daggerpress.com/2008/08/'> August 2008 &nbsp;(37)</option>
	<option value='http://www.daggerpress.com/2008/07/'> July 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/06/'> June 2008 &nbsp;(25)</option>
	<option value='http://www.daggerpress.com/2008/05/'> May 2008 &nbsp;(29)</option>
	<option value='http://www.daggerpress.com/2008/04/'> April 2008 &nbsp;(22)</option>
	<option value='http://www.daggerpress.com/2008/03/'> March 2008 &nbsp;(24)</option>
	<option value='http://www.daggerpress.com/2008/02/'> February 2008 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2008/01/'> January 2008 &nbsp;(17)</option>
	<option value='http://www.daggerpress.com/2007/12/'> December 2007 &nbsp;(13)</option>
	<option value='http://www.daggerpress.com/2007/11/'> November 2007 &nbsp;(19)</option>
	<option value='http://www.daggerpress.com/2007/10/'> October 2007 &nbsp;(20)</option>
	<option value='http://www.daggerpress.com/2007/09/'> September 2007 &nbsp;(9)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Extras</h4>
<div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87194"><a href="http://www.daggerpress.com/about/" itemprop="url">About The Dagger</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87191"><a href="http://www.daggerpress.com/advertise/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87195"><a href="http://www.daggerpress.com/contact-the-dagger/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87192"><a href="http://www.daggerpress.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87193"><a href="http://www.daggerpress.com/terms-of-service/" itemprop="url">Terms of Service</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Sign up for The Daily Dagger Email</h4>
<p>Enter your email address to subscribe to The Daily Dagger and receive new articles by email.</p>
			<form id="subscribeenews-ext-2" action="http://daggerpress.us1.list-manage.com/subscribe/post?u=f122fc2efbaa26a07407ca509&amp;id=c2e87fee01" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2">
												<label for="subbox" class="screenread">Enter your email address...</label><input type="email" value="" id="subbox" placeholder="Enter your email address..." name="" required="required" />
								<input type="submit" value="Go" id="subbutton" />
			</form>
		</div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="facebook-likebox-2" class="widget widget_facebook_likebox"><div class="widget-wrap">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/daggerpress" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/daggerpress"><a href="https://www.facebook.com/daggerpress"></a></blockquote></div>
		</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="gototop"><p></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2021 ·Dagger Press LLC · <a href="http://www.daggerpress.com/wp-login.php">Log in</a></p></div></div></footer>	<div style="display:none">
	<div class="grofile-hash-map-9943ada0a4ac662b8adc37ee7819c8c9">
	</div>
	</div>
<style type="text/css" media="screen"></style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.daggerpress.com\/2021\/05\/05\/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event\/":113050};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2021/05/05/harford-legislators-address-business-community-at-harford-chambers-legislative-wrap-up-event/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://www.daggerpress.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.daggerpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202118' id='devicepx-js'></script>
<script type='text/javascript' id='wp_ulike-js-extra'>
/* <![CDATA[ */
var wp_ulike_params = {"ajax_url":"http:\/\/www.daggerpress.com\/wp-admin\/admin-ajax.php","notifications":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=3.5.2' id='wp_ulike-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LdCX6gaAAAAAK8r_WU2EYou4H27vurj2Dg_FQ-I&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LdCX6gaAAAAAK8r_WU2EYou4H27vurj2Dg_FQ-I","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.3.2' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' id='jetpack-facebook-embed-js-extra'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js' id='jetpack-facebook-embed-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.8.1' id='postmessage-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.8.1' id='jetpack_resize-js'></script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.8.1' id='jetpack_likes_queuehandler-js'></script>
<script async="async" type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.daggerpress.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202118#ver=202118' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202118.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'2163858',post:'113050',tz:'-4',srv:'www.daggerpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '2163858', '113050' ]);
</script>
</body></html>
